В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Boba35
Boba35
03.11.2021 12:12 •  Информатика

Язык программирования си! проверить можно на онлайн компиляторах типа "репл ит" нужна только вторая лаборатория 5 состоит из двух частей: • программирование текстового доступа к файлу; • программирование работы с бинарным доступом к файлу. для обеих программ необходимо подготовить исходные файлы: • для текстового файла — не менее 10 строк; • для двоичного файла — не менее 10 структур, которые соответствуют определенной опции. для работы с файлами должно быть разработано меню, элементы, которые реализуются только с функций. пункты меню должны быть следующими: создать новый файл; • открыть файл; • просмотр файла (листать вперед, назад, в конце файла, в начале файла); • коррекция файлов — долог, исправление, удаление данных; • сохранение файла; • сохранить файл • закройте файл. меню может быть дополнено дополнительными предметами, в зависимости от варианта. имена файлов должны водиться по запросу с клавиатуры. установка второй в дополнение к вышеперечисленным требованиям программа должна удовлетворять следующим условиям: 1. для записи структуры в файл и считывания структуры файла необходимо использовать функции fread () и fwrite 2. чтобы удалить и добавить элементы в файл, необходимо использовать arro вторичный файл. 3. запись не должны быть удалены из файла немедленно, но только помечены как удаленные. в окне просмотра необходимо отображать или активно записи или помечены как удаленные, но не оба типа записей в то же время. поле структуры — это статус записи — он может содержать 0 (активный знак записи) или 1 (удаленный знак записи). при создании файла в этом поле необходимо записать 0, а при удалении записи из файла 1. 4. там должна быть возможность восстановить удаленные записи из списка удаленных, но только до сжатого файла (см. ниже). 5. вы должны выполнить хранение файла данных в двух режимах —со сжатием и без сжатия. в первом случае, записи, помеченные как удаленные, выбрасываются, во втором случае файл записывает все записи, сохраняя их состояние. 6. файл данных должен быть реализован в двоичном режиме, т.е. записи должны храниться как образы в базовой памяти компьютера. 1 работа с текстовыми файлами (строка ввода-вывода) 1. скопируйте файл f2 строки из f1, которые не имеют те же слова. 2. определите количество гласных в первой строке файла f2. 2 работа с бинарными файлами (блочный ввод-вывод) 1. "владелец автомобиля": • фамилия, имя, отчество; • номер автомобиля; * телефон • номер телефона; • статус записи. 2. удалите предмет с заданным техническим номером паспорта. 3. добавьте два элемента после пункта с заданной фамилией.

Показать ответ
Ответ:
TheSniper
TheSniper
30.01.2021 08:38
//Pascal ABC.NET v3.0 сборка 1111

var
 i,a,b:integer;
 ar:array[1..10] of integer;

 procedure oddDec(var a,b:integer);  //подпрограмме переданы аргументы a и b
//процедура для вычитания в нечётном элементе
begin;
a:=a-b;
end;

procedure NotoddInc(var a,b:integer); //подпрограмме переданы аргументы a и b
//процедура для сложения в чётном элементе
begin;
a:=a+b;
end;

begin
randomize;
readln(a); //ввод a
readln(b); //ввод b
writeln('Array:');
for i:=1 to 10 do //весь массив
 begin;
  ar[i]:=random(-20,80); //случайные числа от -20 до 80 включительно
  write(ar[i]:4); //вывод
  if odd(i) then oddDec(ar[i],b) else NotoddInc(ar[i],a);
  {если нечётное, то первая процедура, иначе вторая. Обращаю внимания на то, что элементы меняются сразу после вывода}
 end;
writeln;
writeln('Final array:'); //вывод получившегося массива
for i:=1 to 10 do
write(ar[i]:4);
end.

Пример ввода:
20
10
Пример вывода:
Array:
  10  16   0  60  23   4  22 -20   4  55
Final array:
   0  36 -10  80  13  24  12   0  -6  75  
0,0(0 оценок)
Ответ:
Evgen2100zzz
Evgen2100zzz
19.01.2020 02:09

Лента в Microsoft Word позволяет максимально быстро получить доступ к наиболее часто используемым командам. Лента содержит огромное количество команд, которые разбиты по смысловым группам. В этом уроке Вы узнаете, из каких вкладок состоит Лента, а также научитесь скрывать ее, чтобы увеличить рабочую область Word на экране монитора.

Если Вы ранее пользовались Word 2010 или 2007, тогда Word 2013 покажется Вам знакомым. В нем используются все те же Лента и Панель быстрого доступа, где можно найти команды для наиболее часто используемых задач, а также представление Backstage.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота