В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vlada051199
vlada051199
23.07.2022 19:43 •  Информатика

Язык Python. Напишите программу, которая будет выводить, какую по счёту дощечку прибили.

Формат ввода
Сначала вводится число – сколько нужно дощечек.
Затем вводятся строки, пока не будет введена строка КОНЕЦ

Формат вывода
Строки, в которых нет слова доска или дощечка, игнорируются. Если хотя бы одно из слов есть, то выводим:
Прибили {номер} дощечку.

Как только все прибили, на дальнейший ввод не обращаем внимание и выводим:
ГОТОВО

Если не хватило, то вывести в конце:
МАЛОВАТО​

Показать ответ
Ответ:
Irynadv
Irynadv
02.01.2021 18:53

x = int(input())

s = ''

c = 0

while s != 'КОНЕЦ':

   s = input()

   if 'доска' in s or 'дощечка' in s:

       c += 1

       print('Прибили', c, 'дощечку.')

   if c == x:

       break

if c != x:

   print('МАЛОВАТО')

else:

   print('ГОТОВО')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота