В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
xKarishax
xKarishax
14.12.2020 20:33 •  Информатика

Язык:python Ограничение памяти: 256M
Оставшиеся посылки: 100
Праздничный торт
Пете подарили на день рождения прямоугольный торт размера Ах В сантиметров. Петя не может дождаться
праздничного ужина, поэтому очень хочет заранее отрезать себе k кусков так, чтобы гости ни о чем не догадались.
Для этого Петя придумал следующий план: он будет отрезать кусочки шириной 1 сантиметр от любого края торта,
таким образом уменьшая либо A, либо B на 1 сантиметр. При этом, Петя хочет сделать так, чтобы после отрезания
К кусочков площадь торта осталась максимально возможной.
Вам даны длины сторон исходного торта A, B и количество кусочков К. Напишите программу, которая определит,
каких размеров должен оказаться торт после отрезания K кусочков, если его площадь максимально возможная.
Входные данные
В первой строке дано целое число А
Во второй строке дано целое число в
длина торта (1 - ширина торта (1 количество отрезанных кусочков (1< К В третьей строке дано целое число К
Выходные данные
Выведите два числа через пробел длину и ширину (в любом порядке) торта максимально возможной площади,
полученного после отрезания к кусочков от исходного торта.
Написать это все на питоне

Показать ответ
Ответ:
Polina19790
Polina19790
01.04.2023 12:25
1. #include
using namespace std;
int main (){
int a, b;
cout << "Введите числа: " << endl;
cin >> a >> b;
if (a < b){
cout << "Минимальное число - первое." << endl;
}
else if (a==b){
cout << "Числа равны." << endl;
}
else {
cout << "Минимальное число - второе." << endl;
}
}

2. #include
using namespace std;
int main (){
int a;
cout << "Сколько часов играет Тим?" << endl;
cin >> a;
if(a >= 8){
cout << "Тим здоров." << endl;
}
else {
cout << "Тим болен." << endl;
}
}
0,0(0 оценок)
Ответ:
elezavetkavtoray
elezavetkavtoray
14.11.2021 23:12
1.
const n=15;
var
  c:array[1..n] of integer;
  i,j,t:integer;
begin
  Randomize;
  Writeln('Исходный массив:');
  for i:=1 to n do begin
    c[i]:=Random(51)-25;
    Write(c[i],' ')
  end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-i do
      if c[j]>c[j+1] then
      begin t:=c[j]; c[j]:=c[j+1]; c[j+1]:=t end;
  Writeln('Отсортированный массив:');
  for i:=1 to n do Write(c[i],' ');
  Writeln
end.

Пример:
Исходный массив:
4 10 7 -2 -3 22 0 0 -18 1 9 21 -7 3 25
Отсортированный массив:
-18 -7 -3 -2 0 0 1 3 4 7 9 10 21 22 25

2.
const n=10; m=7;
var 
c1_2:array[1..n,1..m] of integer;
i,j,t:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   c1_2[i,j]:=random(100);
   write(c1_2[i,j]:4);
  end;
  writeln;
 end;
 for j:=1 to m do
  begin t:=c1_2[5,j]; c1_2[5,j]:=c1_2[7,j]; c1_2[7,j]:=t; end;
writeln('Преобразованный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do write(c1_2[i,j]:4);
 writeln;
 end;
end.

Пример:
Исходный массив:
  42  71   0  63  70  87  49
  37  60  15  94  34  28  50
  44  65  71  76  83   0  52
  53  98   4  59  67  32  20
  74  20  43  86   8  56  85
  51  36  35  37  53  32  11
  50  45  22  63   0   7  52
  48   3  81  27   3  36   3
  57  57  88  14  69  13   3
   2  95  57  63  74  77  91
Преобразованный массив:
  42  71   0  63  70  87  49
  37  60  15  94  34  28  50
  44  65  71  76  83   0  52
  53  98   4  59  67  32  20
  50  45  22  63   0   7  52
  51  36  35  37  53  32  11
  74  20  43  86   8  56  85
  48   3  81  27   3  36   3
  57  57  88  14  69  13   3
   2  95  57  63  74  77  91
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота