В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Sanya339
Sanya339
14.03.2021 11:25 •  Информатика

Язык - Python
Развернуть элементы с нечетными индексами
Вам дан список целых чисел. Разверните элементы с нечетными индексами.
Входные данные
Вводится список чисел. Все числа списка не превосходят по модулю 100 и находятся на одной строке.
Выходные данные
Выведите получившийся список.
Примеры
Ввод
1 2 3 4 5
Вывод
1 4 3 2 5

Показать ответ
Ответ:
suleymanovrusl
suleymanovrusl
15.10.2020 14:49

--- Python 3.8.3 ---

RawList = list(map(int, input().split()))

fLen = len(RawList)

HalfLen = fLen//2

for i in range(1, HalfLen+1, 2):

   RawList[i], RawList[fLen-i-1] = RawList[fLen-i-1], RawList[i]

print(*RawList)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота