В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
livanatalya
livanatalya
23.04.2023 00:19 •  Информатика

язык PYTHON

Задание 1 По заданным координатам точек А и В вычислите длину отрезка АВ.

А(xa,ya) B(xb,yb)

Задание 2 Известны длины сторон треугольника a, b, c.

Напишите блок-схему и программу, вычисляющую площадь этого треугольника.

Задание 3. Запишите на языке Python программу, которая для произвольного двузначного числа определяет:

а) сумму и произведение его цифр;

б) число, образованное перестановкой цифр исходного числа.

Задание 4 Составьте программу, выводящую True, если высказывание является истинным, и False в противном случае:

а) сумма цифр трёхзначного числа x является чётным числом;

б) треугольник со сторонами a, b, с является разносторонним

Показать ответ
Ответ:
WowRenka
WowRenka
25.06.2021 07:43

Напишите программу (python), которая соберет все подарки Иа от всех друзей.

Формат ввода

Целое число — количество строк, затем сами строки, в которых сначала вводится подарок, а потом через дефис, окруженный пробелами, имя друга.

Формат вывода

Вывести для каждого друга (друзья выводятся в обратном алфавитном порядке) список его подарков Иа, но уже в алфавитном порядке. Формат вывода:

Друг: подарок, подарок, подарок

Ввод

5

Букет из чертополоха - Кролик

Бант для хвоста - Кристофер Робин

Гвоздик для хвоста - Кристофер Робин

Спаржевый пудинг - Кролик

Зеленая тряпочка - Пятачок

Вывод

Пятачок: Зеленая тряпочка

Кролик: Букет из чертополоха, Спаржевый пудинг

Кристофер Робин: Бант для хвоста, Гвоздик для хвоста

0,0(0 оценок)
Ответ:
ззннааййккаа
ззннааййккаа
26.11.2020 18:20
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
function Euclid(a,b:integer):integer;
begin
  while a<>b do if a>b then a-=b else b-=a;
  Result:=a
end;

begin
  var a,b,c,d:integer;
  Write('Числитель и знаменатель первой дроби: ');
  Read(a,b);
  Write('Числитель и знаменатель второй дроби: ');
  Read(c,d);
  var zn:=b*d;
  var ch:=a*d-c*b;
  var sgn:=Sign(ch); ch:=Abs(ch);
  var gcd:=Euclid(ch,zn);
  Write('Результат вычитания: ');
  if sgn=-1 then Write('-');
  Writeln(ch div gcd,'/',zn div gcd)
end.

Тестовое решение:
Числитель и знаменатель первой дроби: 7 12
Числитель и знаменатель второй дроби: 3 4
Результат вычитания: -1/6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота