Написать программу, которая выдает значение функции Y = 6x2 + arctg(x), угол вводится в градусах. Перевод в радианы и поиск значения Y выполнить в функции, куда x передается в виде параметра.
Var mas:array[1..1000, 1..1000] of integer; N,M,i,j,k:integer;
Begin Writeln('Введите размер матрицы N*M'); Write('N = '); readln(N); Write('M = '); readln(M);
if (M>1000) or (N>1000) or (M<1) or (N<1) then Writeln('Ошибка, указанные значения выходят за пределы матрицы') else Begin Writeln('Введите элементы матрицы');
k:=0; for i:=1 to N do for j:=1 to M do Begin readln(mas[i,j]); if (mas[i,j] mod 2 = 0) then k:=k+1; end;
Writeln(); Writeln('Исходная матрица');
for i:=1 to N do Begin for j:=1 to M do Begin Write(mas[i,j], ' ') end; Writeln(); end;
Writeln(); Writeln('Количество четных элементов = ',k); end;
uses crt;
Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;
Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);
if (M>1000) or (N>1000) or (M<1) or (N<1)
then
Writeln('Ошибка, указанные значения выходят за пределы матрицы') else
Begin
Writeln('Введите элементы матрицы');
k:=0;
for i:=1 to N do
for j:=1 to M do
Begin
readln(mas[i,j]);
if (mas[i,j] mod 2 = 0) then k:=k+1;
end;
Writeln();
Writeln('Исходная матрица');
for i:=1 to N do
Begin
for j:=1 to M do
Begin
Write(mas[i,j], ' ')
end;
Writeln();
end;
Writeln();
Writeln('Количество четных элементов = ',k);
end;
readln;
end.
использовать Чертежник
алг ключ
нач
сместиться в точку (1,1)
опустить перо
сместиться в точку (2,1)
сместиться в точку (2,2)
сместиться в точку (3,2)
сместиться в точку (3,3)
сместиться в точку (7,3)
сместиться в точку (7,1)
сместиться в точку (11,1)
сместиться в точку (11,6)
сместиться в точку (7,6)
сместиться в точку (7,4)
сместиться в точку (1,4)
сместиться в точку (1,1)
поднять перо
сместиться в точку (8,2)
опустить перо
сместиться в точку (10,2)
сместиться в точку (10,5)
сместиться в точку (8,5)
сместиться в точку (8,2)
поднять перо
сместиться в точку (0,0)
кон
Объяснение:
Смотри картинку