язык С. Ввести двумерный массив размером m на n. Вычислить среднее арифметическое значение элементов массива, имеющих четные отрицательные значения, или вывести сообщение об отсутствии в массиве таких значений.
Треугольник существует только тогда, когда сумма длин любых его двух сторон больше третьей стороны. Иначе две стороны просто "укладываются" на третьей.
Треугольник является разносторонним, если все его стороны имеют разную длину; треугольник будет равнобедренным, если любые две его стороны равны между собой, но отличны от третьей; и треугольник является равносторонним, когда все его стороны равны.
Прежде чем выяснять вид треугольника, необходимо удостовериться, что треугольник существует.
Если треугольник существует, то можно сначала проверить на неравенство три его стороны. Если они не равны друг другу, то треугольник разносторонний. Если это не так, то следующим шагом будет проверка на равенство всех сторон треугольника. Если все стороны равны, делается вывод о том, что треугольник равносторонний. Иначе остается только один вариант - равнобедренный треугольник.
Треугольник существует только тогда, когда сумма длин любых его двух сторон больше третьей стороны. Иначе две стороны просто "укладываются" на третьей.
Треугольник является разносторонним, если все его стороны имеют разную длину; треугольник будет равнобедренным, если любые две его стороны равны между собой, но отличны от третьей; и треугольник является равносторонним, когда все его стороны равны.
Прежде чем выяснять вид треугольника, необходимо удостовериться, что треугольник существует.
Если треугольник существует, то можно сначала проверить на неравенство три его стороны. Если они не равны друг другу, то треугольник разносторонний. Если это не так, то следующим шагом будет проверка на равенство всех сторон треугольника. Если все стороны равны, делается вывод о том, что треугольник равносторонний. Иначе остается только один вариант - равнобедренный треугольник.
Объяснение:
#include <iostream>
using namespace std;
int main()
{
int a[5];
int k;
int i;
setlocale(LC_ALL, "Russian");
cout << "введите через пробел пять элементов массива a:";
cin>>a[1]>>a[2]>> a[3]>>a[4]>>a[5];
cout <<"Входные данные:";
cout << a[1]<<" "<< a[2]<<" "<< a[3]<<" "<<a[4]<<" "<<a[5]<<endl;
int min=a[1];
for (int i=2; i<=5; i++)
{
if (min>a[i])
{
min=a[i];
k=i;
}
}
cout<<"Минимальный элемент массива:";
cout << min<<endl;
int x=a[k];
for ( i=k; i>1; i--)
{ a[i]=a[i-1];
}
if ( i<=0)
a[1]=min;
else
a[1]=x;
cout <<"Выходные данные:";
cout << a[1]<<" "<< a[2]<<" "<< a[3]<<" "<<a[4]<<" "<<a[5]<<endl;
return 0;
}