Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Sinnysis
20.04.2021 06:12 •
Информатика
Язык си. написать программу заполнения односвязного списка значениями и вывода этих значений. , .
Показать ответ
Ответ:
Xbdjdndskej
02.10.2020 05:40
выбирай
#include <stdio.h>
#include <stdlib.h>
struct LIST {
int number;
struct LIST *next; };
//
void Push(struct LIST** list, int number) {
struct LIST* node = malloc(sizeof(struct LIST));
node->number = number;
node->next = *list;
*list = node; }
//
void Print(const struct LIST* list) {
if (list) {
Print(list->next);
printf("%d ", list->number); } }
//
int main() {
int i = 10;
struct LIST* list = NULL;
while (i--) {
Push(&list, i + 1); }
//---(это разделение разных программ)
0,0
(0 оценок)
Популярные вопросы: Информатика
savikdaniil3
01.06.2022 02:26
Карта является модели? а) образной; б) знаковой; в) смешанной; г) натурной. )...
mccoy04
27.05.2023 11:22
Отгадай, какое слово закодировано в да...
Mileshka141
20.02.2022 09:50
Угадать правильно шифровку и расшифровать слова: абрбабн,прбвилб,мбмб; я уже угадала из абаушкб бабушка ....
PicaChuShiK
20.02.2022 09:50
Какое количество информации содержит мекст из букв и символов алфавита. информация для человека -это знание которые не получает из различных источников....
pandatka4ewa
10.05.2020 13:01
Вс++ ! написать рекурсивную функцию, которая получает целое число n и разбивает его на разряды (отдельно единицы, десятки, сотни, тысячи и т. например: ввод: 12345 результат: 1 2...
sashakoshelem
05.01.2021 03:58
Озеро это статистическая или динамическая модель?...
Duma10
19.09.2021 00:48
Можно ли аналоговый сигнал преобразить в дискретный сигнал...
Аделина2201
23.04.2022 13:03
Найти сумму всех целых чисел от 5 до 15...
GenGis
05.07.2021 18:06
Выберете смешаную модель а)фотография б)схема в)текст г)формула...
musinasim
30.07.2020 22:53
Ученик 9-го класса читает текст со скоростью 220 символов в минуту. при записи использовался алфавит из 32 символов. какой объём информации в байтах получит ученик, если будет читать...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <stdio.h>
#include <stdlib.h>
struct LIST {
int number;
struct LIST *next; };
//
void Push(struct LIST** list, int number) {
struct LIST* node = malloc(sizeof(struct LIST));
node->number = number;
node->next = *list;
*list = node; }
//
void Print(const struct LIST* list) {
if (list) {
Print(list->next);
printf("%d ", list->number); } }
//
int main() {
int i = 10;
struct LIST* list = NULL;
while (i--) {
Push(&list, i + 1); }
//---(это разделение разных программ)