В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
BackTiger007
BackTiger007
17.08.2021 15:44 •  Информатика

Язык Си. Составить программу, которая позволяет найти произведение нечетных цифр трехзначного числа.

Показать ответ
Ответ:
def04565
def04565
08.06.2021 11:14

Решение задания с кодом из условия:

class Task():

   # все эти аттрибуты должны быть не у самого класса Задачи, а у объектов

   description = ''

   importance = 1

   # дату нужно выражать по-другому. datetime и Arrow в

   completion_month = ''

   completion_date = 1

def creation():  # как раз для этого существует __init__

   objective = Task()

   objective.description = input("Введите описание задачи: ")

   objective.importance = int(input("Введите важность задачи (от 1 до 5): "))

   objective.completion_month = input("Введите месяц сдачи: ")

   objective.completion_date = int(input("Введите дату сдачи: "))

   return objective

tasks = [creation(), creation(), creation()]

i = max(tasks, key=lambda task: task.importance)  # находит задачу с максимальной важностью (key=функция, возвращающая важность)

print("Самая важная задача: " + i.description + ", важность- " + str(i.importance) + ", месяц сдачи- " + i.completion_month + ", дата сдачи- " + str(i.completion_date))

i = min(tasks, key=lambda task: task.completion_date)  # находит задачу с максимальной датой сдачи (key=функция, возвращающая дату сдачи)

print("Самая задача: " + i.description + ", важность- " + str(i.importance) + ", месяц сдачи- " + i.completion_month + ", дата сдачи- " + str(i.completion_date))

Более правильное решение:

import datetime

class Task(object):

   def __init__(self, description, priority, due_date):

       self.description = str(description)

       priority = int(priority)

       if priority not in range(1, 6):

           raise ValueError("priority must be 1, 2, 3, 4, or 5")

       self.priority = priority

       if isinstance(due_date, datetime.datetime):

           due_date = due_date.date()

       if not isinstance(due_date, datetime.date):

           raise ValueError("due_date must be datetime.datetime "

                            "or datetime.date")

       self.due_date = due_date

   def __repr__(self):

       return f"Task({self.description}, {self.priority}, {self.due_date})"

   @classmethod

   def from_user_input(cls):

       description = input("Enter description of the task: ")

       while True:

           priority = input("Enter priority of the task (1-5): ")

           if priority in map(str, range(1, 6)):

               priority = int(priority)

               break

       

       date_format = "%d.%m.%Y"

       while True:

           due_date = input(f"Enter due date (like {date_format}): ")

           try:

               due_date = datetime.datetime.strptime(due_date, date_format).date()

           except ValueError:

               pass

           else:

               break

       return cls(description, priority, due_date)

   

tasks = [Task.from_user_input(),

        Task.from_user_input(),

        Task.from_user_input()]

print("The most important task:", max(tasks, key=lambda task: task.priority))

print("The most urgent task:", min(tasks, key=lambda task: task.due_date))

0,0(0 оценок)
Ответ:
Гипопофото
Гипопофото
25.03.2023 08:54

Модель – это представление объектов реального или вымышленного мира и их свойств. Безусловно, она не обладает всеми свойствами того объекта, прототипом которого является

Человек в своей деятельности (научной, художественной, образовательной) постоянно создает и использует модели окружающего мира. В повседневной жизни с представленными в виде моделей или схем примерами мы сталкиваемся постоянно: это может быть схема метрополитена, манекен в витрине магазина, глобус в кабинете географии, портреты в музеях, и т. д. Все художественное творчество можно считать процессом создания моделей. Более того, практически любое литературное произведение можно рассматривать как модель реальной человеческой жизни. В ходе этого урока можно будет более подробно ознакомиться с историей происхождения этого термина и узнать, каким образом и в каких целях человечество использует моделирование.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота