За 1. дано двузначное число. напишите программу , которая определяет: есть ли среди цифр заданного целого двузначного числа одинаковые. 2. написать программу: ввести номер месяца и вывести название времени года. 3. ввести возраст человека (от 1 до 1500 и вывести его вместе с последующим словом "год", "года", "лет". смотри прикрепленный файл.
1 задача
var a: string;
begin
write('Введите двузначное число: ');
readln(a);
writeln((a.First() = a.Last()) ? 'Цифры одинаковы' : 'Цифры различаются');
end.
2 задача
var
month: integer;
season: string;
begin
write('Введите номер месяца: ');
readln(month);
case month of
1,2,12: season := 'Зима';
3..5: season := 'Весна';
6..8: season := 'Лето';
9..11: season := 'Осень';
else season := 'Вы ввели неверный номер месяца';
end;
writeln(season)
end.
3 задача
var
age: integer;
ending: string;
begin
write('Введите возраст: ');
readln(age);
if (age mod 100 >= 10) and (age mod 100 <= 20)
then ending := 'лет'
else
case (age mod 10) of
1: ending := 'год';
2..4: ending := 'года';
5..9, 0: ending := 'лет'
end;
write(age, ' ', ending)
end.