За ответ от Можете написать код для программы С++, для этого задания? Что бы в конце работала программа по данному заданию. Написать программу в C++, которая формирует двумерную матрицу чисел размерностью n*n. Затем формирует два одномерных массива, причем в один записываются элементы, расположенные на главной диагонали и выше, в другой – элементы матрицы, лежащие ниже главной диагонали и выводит все массивы на экран. Осуществить бинарный поиск заданного элемента во втором массиве. Результаты поиска вывести на экран.
3) X˅Y˅¬Z
Объяснение:
) ¬X^¬Y^¬Z конъюнкция истина тогда и только тогда когда все операнды логической операции истины, данная операция соответствует только первой строке и больше никакой , следовательно не оно
2) X^¬Y^¬Z конъюнкция истина тогда и только тогда когда все операнды логической операции истины, данная операция соответствует только последней строке и больше никакой , следовательно не оно
3) X˅Y˅¬Z дизъюнкция ложна тогда и только тогда когда все операнды логической операции ложны, данная операция соответствует всем строкам в таблице, следовательно оно
4) ¬X˅Y˅Z дизъюнкция ложна тогда и только тогда когда все операнды логической операции ложны, данная операция соответствует первой и второй строке, но не последней, следовательно не оно
ответ 3)3) X˅Y˅¬Z
1 вариант
Pascal
Var
n,k,i:integer;
X,A,f,C:Real;
begin
k:=1;
Writeln('Введите N');
Readln(n);
Writeln('Введите X');
Readln(x);
Writeln('Введите A');
Readln(a);
F:=(exp(ln(X/A)*1))/1;
for i:=2 to n do begin
k:=k*i;
C:=(exp(ln(X/A)*N))/K;
F:=F+C;
end;
Writeln(F);
end.
2 вариант
var
X, A, F : Real;
i, N : Integer;
begin
Write('n = '); ReadLn(N);
Write('x = '); ReadLn(X);
Write('a = '); ReadLn(A);
F := 1;
Sum := F;
for i := 1 to N do
begin
F := F * (X / A) / i;
Sum := Sum + F;
end;
WriteLn(Sum:0:5);
end.