Задача 1. С оператора выбора case of реализовать алгоритм: Программа получает число от 1 до 7 и возвращает название дня недели.
Задача 2. В программу вводятся 5 чисел, после чего она выводит сообщение: «Введите 1, чтобы рассчитать сумму чисел. Введите 2, чтобы рассчитать произведение чисел. Введите 3, чтобы рассчитать среднее арифметическое». Напишите программу, которая работает соответственно приведённому алгоритму.
Принтер (англ. printer от print «печать») — это внешнее периферийное устройство компьютера, предназначенное для вывода текстовой или графической информации, хранящейся в компьютере, на твёрдый физический носитель, обычно бумагу или полимерную плёнку, малыми тиражами (от единиц до сотен).
Этим принтеры отличаются от полиграфического оборудования и ризографии, которое за счёт печатной формы быстрее и дешевле на крупных тиражах (сотни и более экземпляров).
Принтер — это высокотехнологичное устройство печати, созданное в первую очередь для работы с компьютером. Принтер предназначен для преобразования информации, хранящейся в вычислительном устройстве, из цифровой формы в аналоговый вид для доступного понимания этой информации пользователем и последующего долговременного её хранения.
Получили также распространение и другие устройства печати, такие, как многофункциональные устройства (МФУ), в которых в одном приборе объединены функции принтера, сканера, копировального аппарата и телефакса. Такое объединение рационально с технической и экономической стороны, а также удобно в работе.
Специализированной разновидностью принтера является плоттер.
Длина стороны может быть определена как расстояние между соответствующими сторонами треугольника:
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
type
Point=record
x,y:real
end;
procedure GetPoint(c:char;var M:Point);
begin
Write('Введите координаты точки ',c,': ');
Read(M.x,M.y)
end;
function Dist(a,b:Point):=sqrt(sqr(b.x-a.x)+sqr(b.y-a.y));
begin
var A,B,C:Point;
GetPoint('A',A); GetPoint('B',B); GetPoint('C',C);
var ab:=Dist(A,B);
var bc:=Dist(B,C);
var ac:=Dist(A,C);
if (ab<bc+ac) and (bc<ab+ac) and (ac<ab+bc) then
Writeln('Треугольник существует')
else Writeln('Треугольник не существует')
end.
Тестовое решение:
Введите координаты точки A: -6.9 -5.3
Введите координаты точки B: 0 11.4
Введите координаты точки C: 9 3
Треугольник существует