Задача №2: составить программу для вычисления значения функции по одной из формул Программа:
CLS
REM Значение функции
INPUT «Введите a, b, x»; a, b, x
IF x<10 THEN y=x+a: GOTO 1 ELSE y=SIN(x)-b: GOTO 1
1 PRINT “y=”; y
END
Задание.
Составить блок схему данной программы.
class ArrayMiddle{
public static void main(String args[]){
java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
while((eArray[eArray.length-1] = in.nextLong())!=-1){
long nArray[] = new long[eArray.length+1];
for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
eArray = nArray;
} eArray[eArray.length-1] = 0;
for(int cCell = 0; cCell<eArray.length-1; cCell++)eArray[eArray.length-1]+=eArray[cCell];
System.out.print(eArray[eArray.length-1]/(double)(eArray.length-1));
}
}
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
Writeln('Ср.арифм=',ArrRandom(30,0,1000).Println(', ').
Where(x->Odd(x)).Average)
end.
Тестовое решение:
611, 443, 634, 637, 44, 297, 286, 431, 130, 767, 388, 513, 827, 681, 619, 810, 586, 697, 206, 823, 294, 238, 354, 138, 411, 141, 873, 864, 715, 564
Ср.арифм=592.875
И пояснение, как это работает, т.е. по сути алгоритм на русском языке.
ArrRandom(30,0,1000) создает массив из 30 элементов и заполняет его случайными значениями из диапазона [0,1000]. Далее этот массив обрабатывается методом Println, который направляет значения элементов на вывод, разделяя их запятой с последующим пробелом и в конце вывода добавляет смену строки. Затем элементы массива проходят фильтр Where(x->Odd(x)), который пропускает через себя только те значения, которые удовлетворяют условию Odd(значение элемента)=True, а мы знаем, что Odd() возвращает True для нечетного аргумента. Далее фильтр элементы обрабатываются методом Average, который умеет принимать набор значений и возвращать их среднее. И наконец, процедура Writeln выводит полученное значение, предваряя его текстовым пояснением.