В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sof2008
sof2008
20.08.2021 19:49 •  Информатика

ЗАДАЧА C++ Напишите программу, которая считывает число x, а затем пишет его, поставив перед ним х пробелов
Формат входных данных
Целое не отрицательное число x (Гарантируется, что x не меньше нуля и не больше 9)
Формат выходных данных
Число x, перед которым стоит x пробелов.

Показать ответ
Ответ:
derzhak12345
derzhak12345
04.01.2021 00:56

#include <iostream>

using namespace std;

int main() {

   int x;

   cin >> x;

   for (int i = 0; i < x; i++) cout << " ";

   cout << x;

}

Объяснение:

0,0(0 оценок)
Ответ:
alina97531
alina97531
04.01.2021 00:56

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_CTYPE,"Russian");

int x;

cin >>x;

if(x>0 && x<9)

{

for(int i= 0; i<x; i++)

{

cout << " ";

}

cout<<x;

}

else cout<<"Число х не соответсвует диапазону";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота