В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
POMIDOrio
POMIDOrio
04.07.2021 21:01 •  Информатика

Задача: Дан двумерный массив целых чисел. Количество столбцов определено в константе MAX_COL (описывать не надо), количество строк определено в константе MAX_ROW (описывать не надо).

Необходимо найти максимальный элемент массива и поменять у него знак на противоположный. Вывести полученный массив.

Формат ввода:

Массив целых чисел задан построчно, через 1 пробел. Числа в диапазоне от -30000 до 30000

Формат вывода:

Массив целых чисел построчно, через 1 пробел.

Пример входных данных

12 3 11
-2 31 1
Пример выходных данных

12 3 11
-2 -31 1
Пояснение:

Отсутствует.

Показать ответ
Ответ:
Vladttttt
Vladttttt
01.09.2020 17:58

ответ:1) (1 б.) Верные ответы: 3;

2) (1 б.) Верные ответы: 4;

3) (1 б.) Верные ответы: 1; 2;

4) (1 б.) Верные ответы: 3;

5) (1 б.) Верные ответы: 1;

6) (1 б.) Верные ответы: 3;

7) (1 б.) Верные ответы: 4;

8) (1 б.) Верные ответы: 1;

9) (1 б.) Верные ответы: 3;

10) (1 б.) Верные ответы: 3;

11) (1 б.) Верные ответы: 2;

12) (1 б.) Верные ответы: 3;

13) (1 б.) Верные ответы: 4;

14) (1 б.) Верные ответы: 1;

15) (1 б.) Верные ответы: 1; 2;

16) (1 б.) Верные ответы: 1;

17) (1 б.) Верные ответы: 2;

18) (1 б.) Верные ответы: 1;

19) (1 б.) Верные ответы: 3;

20) (1 б.) Верные ответы: 2;

21) (1 б.) Верные ответы: 2;

Объяснение:

0,0(0 оценок)
Ответ:
vika3v
vika3v
16.06.2020 09:13

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота