В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
anastasiysu77
anastasiysu77
25.01.2021 21:56 •  Информатика

Задача: Дано целое число N. Написать программу, заменяющую его нулем, если число меньше нуля и увеличивающую его на 4, если число больше либо равно нулю . В ПАСКАЛЕ

Показать ответ
Ответ:
rimmarimma84
rimmarimma84
28.12.2020 19:38

begin

 var N := readinteger;

 if (N < 0) then

   N := 0

 else

   inc(N, 4);

 write(N);

end.

Объяснение:

begin  // Начало программы

 var N := readinteger;  // Считываем значение переменной N с клавиатуры

 if (N < 0) then  // Если значение переменной N < 0, тогда

   N := 0  // Значение переменной N = 0

 else  // Иначе

   inc(N, 4);  // Увеличиваем значение переменной N на 4

 write(N);  // Выводим значение переменной N

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота