В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
тусикк
тусикк
07.08.2021 10:51 •  Информатика

Задача для Python по теме множества
Напишите программу, которая находит все различные цифры в символьной строке.
Входные данные
На вход программе подаётся символьная строка.
ыходные данные
Программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. Если в строке нет цифр, нужно вывести слово 'NO'.

Показать ответ
Ответ:
vamp9991
vamp9991
12.10.2020 01:07

string = input().split()

number_list = []

for elem in string:

   if elem.isdigit() == True:

       number_list.append(elem)

number_list.sort()

if len(number_list) == 0:

   print('NO')

else:

   print(number_list)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота