В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Lenaaaa111
Lenaaaa111
31.03.2023 01:32 •  Информатика

Задача на программирование. Язык Pascal. Дано целое число n. Разделите числа 1,2,...,n на три множества с одинаковой суммой или выясните, что это невозможно.
Формат входных данных:
В первой строке записано целое число n (1 >, а в следубщих трёх строках - сами множества: каждое число от 1 до n должно оказаться ровно в одной из этих трёх строк. Разделяйте числа в каждой строке пробелом. Поядок чисел в строке может быть любым. Если возможных ответов несколько, выведите любой из них. Если же такое разделение невозможно, в первой строке выведите >.
Примеры:
Стандартный вывод Стандартный ввод
6 YES
1 6
2 5
3 4

Показать ответ
Ответ:

Инструмента́льное програ́ммное обеспе́чение — программное обеспечение, предназначенное для использования в ходе проектирования, разработки и сопровождения программ, в отличие от прикладного и системного программного обеспечения.

Один из наиболее известных языков программирования, используется для обучения программированию в старших классах является Pascal.

Бе́йсик (Basic) — семейство высокоуровневых языков программирования. Был разработан в 1964 году профессорами Дартмутского колледжа Томасом Курцем и Джоном Кемени.

Word — текстовый процессор, предназначенный для создания, просмотра, редактирования и форматирования текстов статей, деловых бумаг, а также иных документов.

PowerPoint- программа для созданий презентаций

0,0(0 оценок)
Ответ:
aminazhum
aminazhum
02.06.2021 17:03
 1.
#include <iostream> //если не отображается, пиши после include - iostream в <>
 using namespace std;

 int main(){
  for(int i=0;i<10;i++)
         cout<<"Hello World";
  cin.get();
  cin.get();
  return 0;
 } 11.
#include <iostream> //если не отображается, пиши после include - iostream в <>
#include <string> //если не отображается, пиши после include - string в <>
using namespace std;
int main() {
string s,p;
         cin>>s;
         cin>>p;
         if((p!="v") && (p!="g"))
         return 66;
         int n;
         cin>>n;
         if (p=="g"){
          for(int i=0;i<n;i++)
          cout<<s;
         }
         else
         {
          for(int i=0;i<n;i++)
          cout<<s<<"\n";
         }
         cin.get();
         cin.get();
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота