Задача на Python Самый простой случай в статистике — это когда нужно определить вероятность появления одного из равновероятных событий. Например, выпадения орла или решки при броске монеты. Если бросать монету несколько раз, то вероятность не изменится, монета ничего не знает о результатах наших предыдущих экспериментов.
Но так бывает не всегда. Замечено, что после пасмурного дня скорее всего будет тоже пасмурный, а после ясного — ясный. Допустим, что мы много лет наблюдали за погодой и накопили большой объем статистики и определили вероятность ясного дня после ясного как p, соответственно, пасмурного после ясного как 1 — p; пасмурного после пасмурного как q, тогда ясного после пасмурного 1 — q.
Мы хотим узнать, с какой вероятностью через несколько дней будет определенная погода. Пусть сегодня ясно. Тогда завтра ясно будет с вероятностью p, а пасмурно — 1 — p. А послезавтра?
Остается только определить максимальную вероятность интересующей нас погоды из полученных. Так можно попытаться предсказать погоду на любой день после сегодняшнего. Напишите для этого программу.
Формат ввода
Строка — какая погода сегодня.
Вещественное число — вероятность ясного дня после ясного.
Вещественное число — вероятность пасмурного дня после пасмурного.
Целое число — через сколько дней нам нужен прогноз.
Формат вывода
Вывести прогноз на интересующий нас день — ясно или пасмурно, а также полученную вероятность. Если вероятность одинакова, вывести — равновероятно.
var i: integer; begin // С С С Вывод последовательности 1 3 5 7 9var i,x: integer; begin // С и промежуточной переменной x := 1; for i := 1 to 5 do begin write(x,' '); x := x + 2; end; writeln; // С без промежуточной переменной for i := 1 to 5 do write(2*i-1,' '); writeln; // С С Сумма и произведение введенных чиселКод на Pascalvar i: integer; s,p: real; x: real; begin writeln('Введите 10 чисел: '); s := 0; p := 1; for i := 1 to 10 do begin read(x); s := s + x; p := p * x; end; writeln('Сумма введенных чисел = ',s); writeln('Произведение введенных чисел = ',p); end.Код на PascalABC.NETvar s,p: real; begin writeln('Введите 10 чисел: '); s := 0; p := 1; for var i := 1 to 10 do begin var x: integer; read(x); s += x; p *= x; end; writeln('Сумма введенных чисел = ',s); writeln('Произведение введенных чисел = ',p); end.Вычисление n!Код на Pascalvar n,fact: integer; i: integer; begin write('Введите n (n<=13): '); readln(n); fact := 1; for i := 2 to n do fact := fact * i; writeln(n,'! = ',fact); end.Код на PascalABC.NETvar n: integer; begin write('Введите n (n<=13): '); readln(n); var fact := 1; for var i := 2 to n do fact *= i; writeln(n,'! = ',fact); end.Вычисление AnКод на Pascalvar n,i: integer; a,p: real; begin write('Введите a,n: '); readln(a,n); p := 1; for i := 1 to n do p := p * a; writeln(a,' в степени ',n,' = ',p); end.Код на PascalABC.NETvar n: integer; a: real; begin write('Введите a,n: '); readln(a,n); var p := 1.0; for var i := 1 to n do p *= a; writelnFormat('{0} в степени {1} = {2}',a,n,p); end.
Жёсткий диск ("винчестер", hdd, hard disc drive - eng.) - накопитель информации основанный на магнитных пластинах и эффекте магнетизма. Применяется повсеместно в персональных компьютерах, ноутбуках, ноутбуках, планшетных компьютерах, серверах и так далее. Устройство жёсткого диска.
Объяснение:
В полу герметичном блоке находятся двусторонние пластины, с нанесённым на них магнитным слоем, посаженные на вал двигателя и вращающиеся со скоростью от 5400 оборотов в минуту.Блок не совсем герметичен, но самое главное он не пропускает мелкие частицы и не допускает перепадов влажности. Всё это пагубно сказывается на сроке службы и качестве работы жёсткого диска.
Жёсткий диск ("винчестер", hdd, hard disc drive - eng.) - накопитель информации основанный на магнитных пластинах и эффекте магнетизма. Применяется повсеместно в персональных компьютерах, ноутбуках, ноутбуках, планшетных компьютерах, серверах и так далее. Устройство жёсткого диска.
Объяснение:
В полу герметичном блоке находятся двусторонние пластины, с нанесённым на них магнитным слоем, посаженные на вал двигателя и вращающиеся со скоростью от 5400 оборотов в минуту.Блок не совсем герметичен, но самое главное он не пропускает мелкие частицы и не допускает перепадов влажности. Всё это пагубно сказывается на сроке службы и качестве работы жёсткого диска.