В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ogurtsov2001
ogurtsov2001
07.08.2020 04:00 •  Информатика

задача: напишите программу выводящих на экран список всех программистов и дополнительный список программистов на С++ решить нужно через записи , программу написать на паскаль авс.net сома программа ниже но вместо списка выводится белый экран. то есть программа завершается на слове ввод закончен что не так? Type pr=record nm:string; Ln:string; end; var prog:array[1..3]of pr; i:integer; begin for i:= 1 to 3 do begin Writeln(' Введите Фамилию и имя ',i,'человека'); Readln(prog[i].nm); Writeln(' Введите язык'); Readln(prog[i].Ln); end; Writeln('вВОД ЗАКОНЧЕН'); for i:= 1 to 3 do if prog[i].Ln= 'C ++' then Write(prog[i].Ln); end.

Показать ответ
Ответ:
Greeegooo
Greeegooo
16.04.2023 06:07

Напишу основные идеи на языке Си,но преобразовать несложно Вам будет.

 

1.  int N,c1,c2,razn,chastn;

     scanf ("%d",&N); // запрашиваем двузначное число

     

    c1=N%10;
     N/=10;

     c2=N%10;  

      razn=c2-c1;  chastn=c2/c1;

2. int Z;

     

     if (Z>0)  Z=Z+1;

     if (Z==0) Z=10;

3. int  Z, c_right, c_left;

      

     c_right=Z%10;

      Z=Z/10;    

     c_left=Z%10;

4. int Z;

     if  ( Z%2==0 ) четное ;

     else нечетное ;

5. int a,b,sum ; //имеем ввиду a<b

 

     do

        { a=a+1;

           sum=sum+a;

         }

        while (a!=b-1); //  (a!=b) - если от а до Б включительно

 

Как то так. Если возникнут вопросы- пишите :)

 

      

       

0,0(0 оценок)
Ответ:
Veronika509
Veronika509
15.05.2020 21:09
1.                                                                    

program raf105;

const

 n = 5;

var

 a:array[1..n] of integer;

 x, counter, i: integer;

begin

writeln('Заполните массив:');

for i:=1 to n do

 readln(a[i]);

write('Введите значение элемента, который нужно удалить: ');

readln(x);

for i:=1 to n do

begin

 if counter > 0

   then a[i-counter]:= a[i];

 if (a[i] = x) and (counter < 1)

   then counter:= counter + 1;

end;

writeln('Вывод:');

for i:=1 to n-counter do

 writeln(a[i]);

end.

2.                                                                    

program raf105;

const

 n = 5;

var

 a:array[1..n] of integer;

 x, counter, i: integer;

begin

writeln('Заполните массив:');

for i:=1 to n do

 readln(a[i]);

write('Введите значение элемента, который нужно удалить: ');

readln(x);

for i:=1 to n do

begin

 if counter > 0

   then a[i-counter]:= a[i];

 if a[i] = x

   then counter:= counter + 1;

end;

writeln('Вывод:');

for i:=1 to n-counter do

 writeln(a[i]);

end.

Язык PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота