Задача: Опишите:
тип массив TStroka как массив целых чисел из MAX_NUM элементов (задано константой,описывать не надо) элементов с индексами от 1 до MAX_NUM;
тип массив TTablica как массив из строк целых чисел (TStroka) из MAX_NUM элементов (задано константой,описывать не надо) элементов с индексами от 1 до MAX_NUM;
процедуру procedure Zap(var m: TTablica), которая заполняет массив, заданным образом;
процедуру procedure Vivod(m: TTablica), которая выведет элементы массива в виде таблицы через один пробел.
Формат ввода:
Описан в задаче.
Формат вывода:
Описан в задаче.
Пример входных данных
Описан в задаче.
Пример выходных данных
0 0 0 1
0 0 1 1
0 1 1 1
1 1 1 1
Пояснение:
Отсутствует.
{Напишите программу, которая находит минимальное и максимальное
среди чётных положительных чисел, записанных в файле,
и выводит результат в другой файл.}
var f:text;
min, max,a :integer;
find:boolean;{есть/нет числа удовлетворяющие условию}
begin
assign(f,'dan.txt'); reset(f);
min:=0; max:=0;
find:=false;
while not eof(f) do
begin
read(f,a);
if not find and (a>0) and (a mod 2=0) then
begin
min:=a; find:=true;
end
else
if find and (a>0) and (a mod 2=0) and (min>a) then
min:=a;
if (a>0) and (a mod 2=0) and (max<a) then
max:=a;
end;
close(f);
assign(f,'res.txt');
rewrite(f);
if max=0 then writeln(f,'чётных положительных чисел нет')
else
writeln(f,'min среди чётных положительных чисел =',min, chr(13),
'max среди чётных положительных чисел нет',max);
close(f);
end.
Подробнее - на -
Объяснение:
среди чётных положительных чисел, записанных в файле,
и выводит результат в другой файл.}
var f:text;
min, max,a :integer;
find:boolean;{есть/нет числа удовлетворяющие условию}
begin
assign(f,'dan.txt'); reset(f);
min:=0; max:=0;
find:=false;
while not eof(f) do
begin
read(f,a);
if not find and (a>0) and (a mod 2=0) then
begin
min:=a; find:=true;
end
else
if find and (a>0) and (a mod 2=0) and (min>a) then
min:=a;
if (a>0) and (a mod 2=0) and (max<a) then
max:=a;
end;
close(f);
assign(f,'res.txt');
rewrite(f);
if max=0 then writeln(f,'чётных положительных чисел нет')
else
writeln(f,'min среди чётных положительных чисел =',min, chr(13),
'max среди чётных положительных чисел нет',max);
close(f);
end.