В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vika2499
vika2499
26.04.2023 10:41 •  Информатика

Задача по C++: Дан набор из N вещественных чисел Xk. Напишите программу,

рассчитывающую количество элементов, попадающих на отрезок

[AB], то есть удовлетворяющих условию A  Xk  B , где А и В – заданные вещественные числа.


Задача по C++: Дан набор из N вещественных чисел Xk. Напишите программу,рассчитывающую количество эл

Показать ответ
Ответ:
fagev
fagev
04.07.2021 09:04

#include <iostream>

using namespace std;

class Set {

   int N, counter = 0;

   float A, B;

public:

   Set(int N, float A, float B) {

       this->N = N;

       this->A = A;

       this->B = B;

   }

   void Count() {

       for (int i = 0; i < N; i++) {

           float x;

           cin >> x;

           if (A <= x && x <= B)

               counter++;

       }

       cout << "Count = " << counter << endl;

   }

};

signed main()

{

   setlocale(LC_ALL, "Rus");

   int N;

   float A, B;

   cout << "Введите число элементов: (N) ";

   cin >> N;

   cout << "\nВведите числа A и B: ";

   cin >> A >> B;

   Set m(N, A, B);

   m.Count();

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота