Задачи на циклы. 6. Составьте программу, вычисляющую A*B, не пользуясь операцией умножения. А и B любое натуральное число. 7. Каждая бактерия делится на две в течение одной минуты. В начальный момент имеется одна бактерия. Составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени (15 минут, 7 минут и т.п.).
8. В 1202г. Итальянский математик Леонард Пизанский (Фибоначчи) предложил такую задачу: пара кроликов каждый месяц дает приплод – двух кроликов (самца и самку), от которых через два месяца уже получается новый приплод, Сколько кроликов будет через год, если в начале года имелась одна пара? Согласно условию задачи числа, соответствующие количеству кроликов, которые появляются через каждый месяц, составляют последовательность 1, 1, 2, 3, 5, 8, 13, 21, 37, … Составьте программу, позволяющую найти все числа Фибоначчи, меньшие заданного числа N.
9. Найти все трехзначные числа, сумма цифр которых равна данному целому числу.
10. Найти все трехзначные числа, средняя цифра которых равна сумме первой и второй цифр.
begin
var a:=ArrRandom(100,-10,10);
a.Println;
Writeln(a.Where(x->x>0).Count,' положительных, ',
a.Where(x->x<0).Count,' отрицательных')
end.
Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
Известно, что наибольший объём информации физически здоровый человек получает при б) органов зрения;
Укажите «лишний» объект с точки зрения вида письменности: в) китайский язык;
По форме представления информацию можно условно разделить на следующие виды: г) визуальную, аудиальную, тактильную, обонятельную, вкусовую;
Дискретизация информации - это: в) процесс преобразования информации из непрерывной формы в дискретную;
Дайте самый полный ответ.При двоичном кодировании используется алфавит, состоящий из: г) любых двух символов (не вполне уверена);
В какой строке единицы измерения информации расположены по возрастанию? г) бит, байт, килобайт, мегабайт, гигабайт;
Объём сообщения равен 11 Кбайт. Сообщение содержит 11 264 символа. Какова мощность алфавита, с которого записано сообщение? в) 256, т.к. мощность алфавита можно найти по формуле 2^i. i = 11 * 1024 * 8 / 11264 = 8 бит, 2^8 = 256.;
Дан текст из 600 символов. Известно, что символы берутся из таблицы размером 16 х 32. Определите информационный объём текста в битах. г) 5400, т.к. дано: 600 символов; размер таблицы равен 16*32=512; 512=2^i=2^9, 9 бит приходится на 1 символ. Всего бит: 600*9=5400;
Два текста содержат одинаковое количество символов. Первый текст составлен из символов алфавита мощностью 16, а'второй текст - из символов алфавита мощностью 256. Во сколько раз количество информации во втором тексте больше, чем в первом? б) в 2 раза, т.к. на символ в алфавите с мощностью 16 требуется 4 бита (2^4 степени), а на символ алфавита мощностью 256 требуется 8 бит (2^8), 8/4=2.
Информационные процессы — это: в) процессы сбора, хранения, обработки, поиска и передачи информации;
В какой строке верно представлена схема передачи информации? б) источник → кодирующее устройство → канал связи → декодирующее устройство → приёмник.