В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
yicayejiw
yicayejiw
21.06.2020 14:28 •  Информатика

Задачи на циклы while . Напишите программу, которая получает на вход положительное число. Если введенное число четное выводятся все четные числа до этого числа, если нечетное выводятся все нечетные числа до этого числа.​

Показать ответ
Ответ:
Dan363
Dan363
11.10.2020 23:12

var

 n: integer;

 i: integer;

begin

 i := 0;

 writeln('Введите число: ');

 readln(n);

 if n mod 2 = 0 then

   while i < n do

   begin

     i := i + 1;

     if i mod 2 = 0 then

       write(i, ' ')

   end

 else

   while i < n do

   begin

     i := i + 1;

     if i mod 2 <> 0 then

       Write(i, ' ')

   end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота