В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
makskot69
makskot69
11.07.2021 21:31 •  Информатика

Задан двумерный массив с из 4-х строк и 4-х столбцов (квадратная матрица). составить программу подсчёта суммы всех отрицательных элементов и суммы элементов по главной диагонали. : 3

Показать ответ
Ответ:
Farys
Farys
26.08.2020 19:19
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(4,4,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var sn:=a.ElementsByRow.Where(t->t<0).Sum;
  Writeln('Сумма отрицательных элементов равна ',sn);
  var sd:=0;
  for var i:=0 to a.RowCount-1 do sd+=a[i,i];
  Writeln('Сумма элементов на главной диагонали равна ',sd);
end.

Пример
*** Исходный массив ***
  55 -36  70  19
  79  14   5  -5
  79  -9 -62  20
 -71  69 -34  66

Сумма отрицательных элементов равна -217
Сумма элементов на главной диагонали равна 73
0,0(0 оценок)
Ответ:
darinakor140197nooii
darinakor140197nooii
26.08.2020 19:19
If(i=j)
{
A[i][j]+=A[i][j]
}
А вообще в инете вбей,cyberforum, найдешь
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота