Задание 1 ( ). Написать программу на Паскале. Даны два действительных числа x и y. Вычислить их удвоенную сумму, разность, произведение и частное.
Задание 2 ( ).
Составить программу на Паскале, которая запросит два вещественных числа и три целых.
Задание 3 ( ).
Написать программу на Паскале для решения задачи. На рисунке изображены параллельные прямые a и b, расстояние между которыми равно 4. Точки A и B принадлежат прямой a, а точки C и D — прямой b. Найти площадь трапеции ABCD, если AB=3, CD=6.
На проверку нужно прислать коды программ и результаты их работы в виде скриншотов окна программы.
//В квадратной матрице A [n, n] определить количество строк упорядоченных //по убыванию суммы и вывести их номера. const n = 50;var A:Array[1..n, 1.. n] of integer;B:Array[1..n] of integer;m,i,j,sum, k, maxS, q:integer;beginwriteln('Введите размер матрицы m');readln(m);for i:= 1 to m dobeginfor j:= 1 to m dobeginA[i,j] := random(100)+1;write(A[i,j]:4);sum:= sum + A[i,j]end;B[i]:= sum;sum:=0;writeln;end;writeln('Сумма в строке ');for i:=1 to m dowriteln(i:2, B[i]:4);writeln('Матрица с убывающими строками');maxS := -1;for i:= 1 to m dobeginfor k:= 1 to m dobeginif B[k]> maxS then beginmaxS:= B[k]; q := k;end;end;B[q]:= 0; maxS := -1;for j:= 1 to m dobeginwrite(A[q,j]:4);end;writeln; end; end.
Var x:Array[1..3] of integer;// координаты точекy:Array[1..3]of integer;// координаты точекs:Array[1..3]of real; // расстояние между точками b:Array[1..3]of real; // длина бессектрисы p: real; beginfor var i:= 1 to 3 dobegin write('Введите координаты ', i ,' точки'); readln(x[i], y[i]); end; writeln('Начало расчетов'); for var i:= 1 to 3 dobegin if (i < 3) then begin s[i] := sqrt((x[i]-x[i+1])* (x[i]-x[i+1]) + (y[i]-y[i+1])* (y[i]-y[i+1])); p := p + s[i]; end else begin s[i] := sqrt((x[i]-x[1])* (x[i]-x[1]) + (y[i]-y[1])* (y[i]-y[1])); p := p + s[i]; end; writeln('Расстояние между ', i ,' и ', i+1,' точками = ', s[i]); end; p := p /2; writeln('полупериметр = ', p); for var i:= 1 to 3 do beginif (i = 1) then b[i] := 2* sqrt(s[1]*s[2]*p * (p - s[3]))/(s[1]+s[2]);if (i = 2) then b[i] := 2* sqrt(s[2]*s[3]*p *(p - s[1]))/(s[2]+s[3]);if (i = 3) then b[i] := 2* sqrt(s[3]*s[1]*p *(p - s[2]))/(s[3]+s[1]); writeln('Длина ', i, ' бессиктрисы ', b[i]); end;end.//определяющую по координатам трёх точек длины биссектрис треугольника,//если таковой существует. (PascalABC)
//по убыванию суммы и вывести их номера.
const n = 50;var A:Array[1..n, 1.. n] of integer;B:Array[1..n] of integer;m,i,j,sum, k, maxS, q:integer;beginwriteln('Введите размер матрицы m');readln(m);for i:= 1 to m dobeginfor j:= 1 to m dobeginA[i,j] := random(100)+1;write(A[i,j]:4);sum:= sum + A[i,j]end;B[i]:= sum;sum:=0;writeln;end;writeln('Сумма в строке ');for i:=1 to m dowriteln(i:2, B[i]:4);writeln('Матрица с убывающими строками');maxS := -1;for i:= 1 to m dobeginfor k:= 1 to m dobeginif B[k]> maxS then beginmaxS:= B[k]; q := k;end;end;B[q]:= 0; maxS := -1;for j:= 1 to m dobeginwrite(A[q,j]:4);end;writeln;
end;
end.
if (i < 3) then begin s[i] := sqrt((x[i]-x[i+1])* (x[i]-x[i+1]) + (y[i]-y[i+1])* (y[i]-y[i+1])); p := p + s[i]; end else begin s[i] := sqrt((x[i]-x[1])* (x[i]-x[1]) + (y[i]-y[1])* (y[i]-y[1])); p := p + s[i]; end;
writeln('Расстояние между ', i ,' и ', i+1,' точками = ', s[i]); end; p := p /2; writeln('полупериметр = ', p); for var i:= 1 to 3 do beginif (i = 1) then b[i] := 2* sqrt(s[1]*s[2]*p * (p - s[3]))/(s[1]+s[2]);if (i = 2) then b[i] := 2* sqrt(s[2]*s[3]*p *(p - s[1]))/(s[2]+s[3]);if (i = 3) then b[i] := 2* sqrt(s[3]*s[1]*p *(p - s[2]))/(s[3]+s[1]); writeln('Длина ', i, ' бессиктрисы ', b[i]); end;end.//определяющую по координатам трёх точек длины биссектрис треугольника,//если таковой существует. (PascalABC)