Задание 1. Оценивается в Составьте программу, которая высчитывает сумму чисел 117 и 88.
Определите остаток от деления чисел 67 и 5.
Задание 2. Оценивается в
Составьте программу, которая выводит на экран строку «Программирование в Phyton». Используя тип данных str. Напишите команду, которая выводит данную строку наоборот.
Задание 3. Оценивается в
Создайте список уроков (на 5 дней), используя программу sep.
Задание 4. Оценивается в
Составьте программу, которая запрашивает у пользователя имя, возраст, номер телефона. Ввод данных должен быть с клавиатуры. Результатом программы должны выйти 3 строки. («Имя», «Возраст», «Номер телефона»).
else writeln('вы должны ввести число от 1 до 11')
end;
writeln('');
end.
program Phone;
var day:integer; time:real; week:array[1..7] of string;
begin
week[7]:='Воскресенье';
week[6]:='Суббота';
week[5]:='Пятница';
week[4]:='Четверг';
week[3]:='Среда';
week[2]:='Вторник';
week[1]:='Понедельник';
write('введите длительность разговора в минутах ');
readln(time);
write('введите номер дня недели ');
readln(day);
writeln(' alphaeus is thinking... ');
case day of
'1'..'5':
begin
writeln(week[day]);
writeln('Сумма без скидки - ', 2.3*time);
writeln('Сумма скидкой - ', 0.8*2.3*time);
writeln('Скидка не предоставляется');
end;
'6','7':
begin
writeln(week[day]);
writeln('Сумма без скидки - ', 2.3*time);
writeln('Сумма скидкой - ', 0.8*2.3*time);
writeln('Вам предоставлена скидка!');
end;
else writeln('вы ввели неправильный номер дня недели')
end;
writeln'');
end.
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Вычисление стоимости телефонного разговора');
Writeln('Введите исходные данные');
var Sm:=ReadReal('Стоимость минуты разговора, руб.');
var M:=ReadInteger('Длительность разговора (целое количество минут)');
var Day:=ReadInteger('День недели (1-понедельник, ... 7-воскресенье)');
var S:=Sm*M*(Day in [1..5]?1.0:0.8);
Writeln('Стоимость разговора, руб ',s:0:2)
end.
Пример
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 1
Длительность разговора (целое количество минут) 6
День недели (1-понедельник, ... 7-воскресенье) 7
Стоимость разговора, руб 4.80