В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
MaFizLike
MaFizLike
22.05.2020 15:22 •  Информатика

Задание 1.Пусть даны координаты трех точек на плоскости. Составьте программу, которая определяла бы вид треугольника равносторонний, равнобедренный
разносторонний, прямоугольный, тупоугольный, остроугольный), если дагные
координаты вершин позволяют его построить. нужно написать программу в c++

Показать ответ
Ответ:
sinjay
sinjay
10.10.2021 09:40

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   double x1, y1, x2, y2, x3, y3, a, b, c;

   

   cout << 'Введите координаты точек треугольника: ';

   cin >> x1;

   cin >> y1;

   cin >> x2;

   cin >> y2;

   cin >> x3;

   cin >> y3;

   

   a = sqrt(pow((x2 - x1), 2) + pow((y2 - y1), 2));

   b = sqrt(pow((x3 - x2), 2) + pow((y3 - y2), 2));

   c = sqrt(pow((x1 - x3), 2) + pow((y1 - y3), 2));

   

   if (a = b = c) {

       cout << "Данный треугольник - равносторонний\n";

   }

   else if (a == b || b == c || a == c ) {

       cout << "Данный треугольник - равнобедренный\n";

   }

   else if (a != b && b != c && a != c) {

       cout << "Данный треугольник - разносторонний\n";

   }

   

   if (c > a && c > b) {

       if (c*c == a*a + b*b) {

           cout << "Данный треугольник - прямоугольный";

       }

       else if (c*c < a*a + b*b) {

           cout << "Данный треугольник - остроугольный";

       }

       else {

           cout << "Данный треугольник - тупоугольный";

       }

   }

   else if (a > b && a > c) {

       if (a*a == b*b + c*c) {

           cout << "Данный треугольник - прямоугольный";

       }

       else if (a*a < b*b + c*c) {

           cout << "Данный треугольник - остроугольный";

       }

       else {

           cout << "Данный треугольник - тупоугольный";

       }

   }

   else {

       if (b*b == a*a + c*c) {

           cout << "Данный треугольник - прямоугольный";

       }

       else if (b*b < a*a + c*c) {

           cout << "Данный треугольник - остроугольный";

       }

       else {

           cout << "Данный треугольник - тупоугольный";

   }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота