В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
сусанна27
сусанна27
27.09.2022 11:42 •  Информатика

Задание: 1. Составить программу для нахождения значения
выражения: k=10n'+5m?

дам 90б​


Задание: 1. Составить программу для нахождения значениявыражения: k=10n'+5m? дам 90б​

Показать ответ
Ответ:
АРИНОЧКА1111111111
АРИНОЧКА1111111111
25.07.2022 07:24
#include <stdio.h>

float vychislenie(float X1, float X2, float Y1, float Y2);
float vqvod_rezultatov(float K1,float K2);

int main(){
    float X1=0,X2=0,X3=0,X4=0;   
    float Y1=0,Y2=0,Y3=0,Y4=0;   
    float K1=0, K2=0;
   
    printf("Vvedite koordinaty pervoj prjamoj cherez probel (X1 Y1 X2 Y2): ");
    scanf("%f %f %f %f", &X1, &Y1, &X2, &Y2);   
    printf("\nA(%.1f ; %.1f), B(%.1f ; %.1f)\n\n", X1, Y1, X2, Y2);   
    printf("Vvedite koordinaty vtoroj prjamoj cherez probel (X1 Y1 X2 Y2): ");  
    scanf("%f %f %f %f", &X3, &Y3, &X4, &Y4);   
    printf("\nC(%.1f ; %.1f), D(%.1f ; %.1f)\n", X3, Y3, X4, Y4);

    K1=vychislenie(X1,X2,Y1,Y2);   
    K2=vychislenie(X3,X4,Y3,Y4);   
    vqvod_rezultatov(K1, K2);

return 0;
}

float vychislenie(float X1, float X2, float Y1, float Y2){

    float K=0;   
    K=((Y2-Y1)/(X2-X1));

return K;
}

float vqvod_rezultatov(float K1, float K2){
   
    printf("\nKoefficient K1 = %.2f\n", K1);   
    printf("Koefficient K2 = %.2f\n", K2);
   
       if(K1==K2){       
                   printf("\nPrjamye parallelny\n");   
              }else{       
                     printf("\nPrjamye ne parallelny\n");   
               }
return 0;
}
0,0(0 оценок)
Ответ:
D202
D202
22.05.2023 00:21
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
function Avg(a:array[,] of integer):real;
begin
  var s:=0; var k:=0;
  foreach var e:integer in a do
    if e>0 then begin s+=e; Inc(k) end;
  if k>0 then Result:=s/k else Result:=1e-100;
end;

begin
  var A:=MatrixRandom(4,4,-50,50); Writeln(A);
  Writeln('Среднее арифметическое положительных равно ',Avg(A):0:3);
  var B:=MatrixRandom(5,5,-30,30); Writeln(B);
  Writeln('Среднее арифметическое положительных равно ',Avg(B):0:3);
  var C:=MatrixRandom(4,5,-25,38); Writeln(C);
  Writeln('Среднее арифметическое положительных равно ',Avg(C):0:3);
end.

Тестовое решение:
[[35,35,5,-47],[14,34,35,-13],[25,-5,35,-29],[-7,10,-12,12]]
Среднее арифметическое положительных равно 24.000
[[-12,-17,-10,19,14],[20,17,-27,-2,16],[-3,-21,30,2,10],[5,-3,-17,-3,18],[0,-26,29,1,-22]]
Среднее арифметическое положительных равно 15.083
[[-5,-11,17,-4,15],[15,17,-24,36,15],[-8,-3,-22,28,-25],[-21,6,12,31,-1]]
Среднее арифметическое положительных равно 19.200
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота