В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Elton17
Elton17
24.12.2021 22:13 •  Информатика

Задание 1. Составить программу табуляции функции f(x) на отрезке [a; b] шагом h. Параметры a, b и h вводит пользователь с клавиатуры.
Задание 2. Найти значение выражения, используя цикл с параметром. Предусмотреть ввод с клавиатуры значений всех
переменных. () = 0,5 cos + sin 2 Дано натуральное n. Вычислить значение выражения = 1 ∙ 2 + 2 ∙ 3 + ⋯ + ∙ ( + 1)

Показать ответ
Ответ:
hilka2
hilka2
21.07.2020 14:42

1)

a = int(input())

b = int(input())

print(min(a,b))

print(max(a,b))

2)

a = int(input())

b = int(input())

c = int(input())

if a > 0 and b > 0 and c > 0:

   print(3)

elif a > 0 and b > 0 or a > 0 and c > 0 or b > 0 and c > 0:

   print(2)

elif a > 0 or b > 0 or c > 0:

   print(1)

else:

   print(0)

Задание 2.

1)

a = input()

if a[0] < a[1] < a[2]:

   print('ДА')

else:

   print('НЕТ')

2)

a = int(input())

b = int(input())

c = int(input())

if (a + b + c) % 3 == 0:

   print("DA")

else:

   print("NET")

0,0(0 оценок)
Ответ:
Yuliaferyuo
Yuliaferyuo
02.04.2021 23:06
Const n=20;
type omas=array[1..n] of integer;
Procedure Del (var z:omas; k:byte); 
var i:byte; 
begin 
for i:=k to n-1 do z[i]:=z[i+1]; 
z[n]:=0; 
end; 
var a:omas; i,b:integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(20);
 write(a[i]:4);
 end;
writeln;
b:=6;
i:=1;
while (i<=n)and(a[i]<>b) do i:=i+1;
if i<=n then
  begin
  Del(a,i);
 writeln('Размерность массива = ',n-1);
 for i:=1 to n-1 do write(a[i]:4);
 writeln;
 end  else writeln('Массив не изменился');
end.
Пример:
  12  13   6   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
Размерность массива = 19
  12  13   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота