В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
viakobchuk
viakobchuk
20.10.2021 07:27 •  Информатика

Задание 1. Составьте программу,(Python) для следующей задачи: Анель хочет, чтобы ей подарили на день рождения плюшевую игрушку, туфли и платье. Если не будет хотя бы одного подарка, она расстроится. Если же подарят все, то она будет счастлива и поблагодарит.

Уровень B. Придумайте свой алгоритм с составным условием и программу к нему.

Показать ответ
Ответ:
кот933
кот933
25.08.2021 20:54
Стакан перемещается на третье место, соответственно чашка на четвертое. Теперь известно, что кофе оказалось посередине, т.е. оно в стакане. Справа и слева чай и молоко. Т.е. в кружке либо чай, либо молоко и в чашке тоже. Но известно, что в бутылке минеральная вода, а по соседству с молоком - квас. В чашке - молоко, в кувшине квас, в кружке чай.
                  кофе чай молоко квас минеральная вода
     бутылка  -        -      -           -        +
     кружка            +      
     чашка                    +    
     стакан    +        -      -          -         -
     кувшин                              +  
0,0(0 оценок)
Ответ:
Mildx
Mildx
08.08.2020 20:37

#arr = [*map(int, input().split(' 0')[0].split())]  если числа вводятся в строчку , то раскомментируйте и используйте эту строку, а инициализацию массива arr и цикл while закомментируйте

arr = []

while 1:

   tmp = int(input())

   if tmp != 0:  # Читаем сколько угодно чисел пока не будет ноль

       arr.append(tmp)

   else:

       break

s = 0  # сумма двузначных чисел

k = 0  # количество двузначных чисел

for i in arr:

   if 10 <= i <= 99:  # итерируемся по циклу и если число двузначное

       s += i  # то прибавляем его к сумме

       k += 1  # счетчик двузначный чисел увеличиваем на один

print(s/k) if k > 0 else print('NO') #если количество двузначных > 0 то выводим среднее арифметическое s/k, если нет то выводим NO

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота