В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Damira123451
Damira123451
20.03.2020 18:48 •  Информатика

Задание 1. Составьте программу вычисления кусочно-заданной функции из таблицы 1 (по
вариантам). Проверьте работо программы на каждом из трех отрезков.
Задание 2. Составьте программу, определяющую принадлежит ли точка с координатами (X,Y)
множеству точек плоскости, изображенному на рисунке.
Задание 3. Решите задачу из лекции (вывод возраста пользователя в правильной форме: год, года,
лет), использую не более трех "веток" при составлении условия.


Задание 1. Составьте программу вычисления кусочно-заданной функции из таблицы 1 (по вариантам). Пров

Показать ответ
Ответ:
aevseeva03
aevseeva03
16.11.2022 09:34

Відповідь:

                                                 2.

#include <iostream>

void result(int a, int b, int c)

{

   if (a + b > c && b + c > a && c + a > b)

       std::cout << (((a * a) + (b * b)) == (c * c) ||

       ((a * a) + (c * c)) == (b * b) || ((c * c) + (b * b))

       == (a * a) ? "Triangel is angle" : "Yes") << std::endl;  

   else

       std::cout << "No";

}

int main()

{

   int a, b, c;

   std::cin >> a >> b >> c;

   result(a, b, c);

   return 0;

}

ДЕРЖИТЕ ЭТО НЕМОГУ СМОТРЕТЬ НА ВАШ КОД ГЛАЗА ВЫЛЕЗАЮТ

Пояснення:

0,0(0 оценок)
Ответ:
sna2003
sna2003
02.06.2023 14:07

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   float summa, count = 0;

   vector<int> result, zero;

   for (int i = 21; i < 200; i++)

   {

       if (i % 3 == 0)

       {

           result.push_back(i);

           count++;

           summa += i;

           if (i % 10 == 0)

           {

               zero.push_back(i);

           }

       }

   }

   cout << R"(Числа которые заканчиваютса нулем )" << endl;

   for (int i = 0; i < zero.size(); i++)

   {

       cout << zero[i] << ' ';

   }

   cout << endl;

   cout << R"(Числа которые кратные 3)" << endl;

   for (int i = 0; i < result.size(); i++)

   {

       cout << result[i] << ' ';

   }

   cout << endl;

   cout << R"(Количество таких чисел = )" << count << endl;

Дальше немного сами подумайте если я это написал и вы это не поняли. Советую учить С++. Потому что вы не будете понимать что вы делаете.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота