В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
KUGOTVIN
KUGOTVIN
15.08.2021 15:19 •  Информатика

Задание 4.1 Составить и записать на языке программирования Visual Basic программу расчета
минимального времени поездки из одного города в другой по шоссе, если в пути встретятся
населенные пункты. Разрешенная скорость движения по шоссе 80 км/час, в населенных пунктах –
60 км/час.
где A – расстояние между городами
n – количество населенных пунктов
l средняя протяженность населенного пункта вдоль шоссе
Ввод данных организуйте при функции InputBox (Данные для расчета программа
запрашивает у пользователя).
Вывод организуйте при метода Print.
Примечание: Время на разгон и торможение не учитывать.
Вывод сопроводите текстовыми пояснениями:
“Расстояние=”
“Количество населенных пунктов=”
“Время в пути=”
Задание 4.2
Составить и записать на языке программирования Visual Basic программу вычисления
значения y по формуле:

y =
9 − 2x
3
3√x
+
√x
2

где x – переменная с любым числовым значением
Ввод x организуйте при функции InputBox (Данные для расчета программа
запрашивает у пользователя).
Вывод организуйте при метода Print.
Примечание: Вывод сопроводите текстовыми пояснениями:
“ X =”
“ Y =”
“Решения нет”

Задание 4.3
Составить программу определения минимального из 10-ти чисел, вводимых пользователем
Ввод данных организуйте при функции InputBox (Данные для расчета программа
запрашивает у пользователя).
Вывод организуйте при метода Print.
Примечание: Вывод сопроводите текстовым пояснением:
“Минимум=”

Задание 4.4
Какое число было введено с клавиатуры, если в результате выполнения программы было
выведено число 10?
Dim a(8) As Single
Dim i As Single
Private Sub Command1_Click()
a(0) = Val(InputBox("Введите число"))
For i = 1 To 8
a(i) = a(i - 1) - 1
x = a(i)
Next i
Print x
End Sub

Задание 4.5
Задан одномерный массив чисел.
Какое число будет напечатано в результате выполнения следующей программы:
Dim x(10) As Integer
Dim k, n As Integer
Private Sub Command1_Click()
x(1) = 36
x(2) = 20
x(3) = 20
x(4) = 41
x(5) = 19
x(6) = 21
x(7) = 15
x(8) = 33
x(9) = 16
x(10) = 24
n = 1
For k = 1 To 10
If x(k) <=x( n) Then
n = k
End If
Next k
Print n
End Sub

Показать ответ
Ответ:
ГогольВася11
ГогольВася11
07.09.2022 03:34
//Блок-схемы в приложении
//Pascal ABC.NET v3.0 сборка 1111

//1
Var
 a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.

//2
Var
 a,b:integer;
begin
 read(a,b);
 if a>b then writeln(b);
 if a=b then writeln('=');
 if a<b then writeln(a);
end.

{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
0,0(0 оценок)
Ответ:
Amyy1
Amyy1
29.03.2023 06:23
1. 2 Массивы объявляются тем же оператором, что и обычные переменные
2. Не корректный вопрос: индекс - это обращения к определенному элементу массива, а у самого массива индекса нет. В вариантах ответа ничего похожего на это нет.
3. 4 Массивы заполняются теми же операторами, что и обычные переменные
4. 1 Есть такой ввода в бейсике - конструкция READ DATA
5. 1 Выведется четвертый элемент массива, т.к. нумерация идет с нуля, и первый имеет номер 0, второй - 1, третий - 2, а четвертый - номер 3, который и запрашивается в выражении А(3)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота