Задание: Используя подпрограммы функции, составить программу, которая будет вычислять значение выражения tg1+tg2+... +tgN ,где N задаётся пользователем. PascalABC.NET.
1. В начале программы объявим переменные, которые будут использоваться в программе. Нам понадобятся переменные N (для задания количества слагаемых), tg (для хранения значения тангенса каждого слагаемого) и сумма (для накопления суммы слагаемых).
```Pascal
var
N: Integer;
tg, сумма: Real;
```
2. Теперь попросим пользователя ввести значение N:
```Pascal
Write('Введите количество слагаемых (N): ');
Readln(N);
```
3. Объявим подпрограмму для вычисления тангенса числа. Она принимает один параметр - число, и возвращает его тангенс. Мы будем использовать встроенную функцию Tan из модуля Math для вычисления тангенса.
```Pascal
function ВычислитьТангенс(Число: Real): Real;
begin
Result := Tan(Число);
end;
```
4. Организуем цикл, который будет повторяться N раз. На каждом шаге цикла будем запрашивать у пользователя число и вычислять его тангенс с помощью подпрограммы ВычислитьТангенс. Затем добавим полученное значение тангенса к сумме слагаемых.
```Pascal
сумма := 0;
for var i := 1 to N do
begin
Write('Введите число ', i, ': ');
Readln(Число);
tg := ВычислитьТангенс(Число);
сумма := сумма + tg;
end;
```
6. Наконец, закончим программу символом окончания:
```Pascal
Readln;
```
Теперь программа готова для работы. Когда пользователь запустит программу, она попросит ввести количество слагаемых N, затем по очереди ввести значения для вычисления тангенсов. После этого программа выведет сумму выражения на экран.
Надеюсь, моя пояснительная записка помогла вам понять, как составить программу для вычисления указанного выражения. Если у вас возникнут вопросы, пожалуйста, дайте знать.
1. В начале программы объявим переменные, которые будут использоваться в программе. Нам понадобятся переменные N (для задания количества слагаемых), tg (для хранения значения тангенса каждого слагаемого) и сумма (для накопления суммы слагаемых).
```Pascal
var
N: Integer;
tg, сумма: Real;
```
2. Теперь попросим пользователя ввести значение N:
```Pascal
Write('Введите количество слагаемых (N): ');
Readln(N);
```
3. Объявим подпрограмму для вычисления тангенса числа. Она принимает один параметр - число, и возвращает его тангенс. Мы будем использовать встроенную функцию Tan из модуля Math для вычисления тангенса.
```Pascal
function ВычислитьТангенс(Число: Real): Real;
begin
Result := Tan(Число);
end;
```
4. Организуем цикл, который будет повторяться N раз. На каждом шаге цикла будем запрашивать у пользователя число и вычислять его тангенс с помощью подпрограммы ВычислитьТангенс. Затем добавим полученное значение тангенса к сумме слагаемых.
```Pascal
сумма := 0;
for var i := 1 to N do
begin
Write('Введите число ', i, ': ');
Readln(Число);
tg := ВычислитьТангенс(Число);
сумма := сумма + tg;
end;
```
5. Выведем полученную сумму на экран:
```Pascal
Writeln('Сумма выражения составляет: ', сумма);
```
6. Наконец, закончим программу символом окончания:
```Pascal
Readln;
```
Теперь программа готова для работы. Когда пользователь запустит программу, она попросит ввести количество слагаемых N, затем по очереди ввести значения для вычисления тангенсов. После этого программа выведет сумму выражения на экран.
Надеюсь, моя пояснительная записка помогла вам понять, как составить программу для вычисления указанного выражения. Если у вас возникнут вопросы, пожалуйста, дайте знать.