В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ariya03
Ariya03
12.10.2020 07:22 •  Информатика

Задание на практическую работу Тема: Составление программ с командами цикла.
Цель работы: Научиться составлять программы с циклическими командами.
Порядок выполнения работы:
1.
а) Составить блок- схему вычисления суммы N первых членов последовательности, где
ai =5 I – I2

б) Исполнить алгоритм при N=3
в) Составить программу на Бейсике, реализующую данный алгоритм.

2.
Составить алгоритм в виде блок-схемы и программу на Бейсике вычисления произведения двузначных нечетных чисел от 10 до 20. Исполнить алгоритм

3.
а) Составить блок схему алгоритма получения таблицы значений функции
y = -5 x2 – 3x + 6
если х [0; 15] h = 4

б) Исполнить алгоритм.
в) Составить программу на Бейсике, реализующую данный алгоритм.

4.
а) Составить блок схему алгоритма получения таблицы значений функции у=0,2sin х, если х меньше или = 5; у=2In(х-5) если х больше 5.
если х принадлежит [- 1; 10] h = 4

б) Исполнить алгоритм.
в) Составить программу на Бейсике, реализующую данный алгоритм

Показать ответ
Ответ:
vladshumigayoypa3u
vladshumigayoypa3u
04.12.2020 04:24
Жесткий диск
По одной из версий, название «винчестер»  накопитель получил благодаря работавшему в фирме IBM Кеннету Хотону, руководителю проекта, в результате которого в 1973 году был выпущен жёсткий диск модели 3340, впервые объединивший в одном неразъёмном корпусе пластины диска и считывающие головки. При его разработке инженеры использовали краткое внутреннее название «30-30», что означало два модуля (в максимальной компоновке) по 30 МБ каждый, что по созвучию совпало с обозначением популярного охотничьего оружия — винтовки «Winchester Model 1894» использующего винтовочный патрон «.30-30 Winchester». Также существует версия, что название произошло исключительно из-за названия патрона, также выпускавшегося Winchester Repeating Arms Company
0,0(0 оценок)
Ответ:
ТаняСажнева486
ТаняСажнева486
18.11.2021 12:37
1
const     n = 10;
 var   
a : array [1..n] of integer; 
  i : integer;     
 begin 
 randomize; 
// Выбери нужный for
  
for i := 1 to n do 
    begin
      a[i] := i;   
   writeln (a[i]);   
 end;
   //a[1]=1,a[2]=2...a[10]=10 
     

//рандомом 
  for i := 1 to n do 
    begin   
  a[i] := 1 + random (9); 
     writeln (a[i]); 
   end;
  end.
2
 const     n = 25; //кол-во элементов
 var  a : array [1..n] of integer;
  i,k : integer;
 begin
  randomize; 
 for i := 1 to n do
   a[i] := -20+random(40);

    k := 0; 
 for i := 1 to n do 
  if a[i] mod 2 =1 then
    k := k +1; 
 writeln (k);
   end.

3
const     n = 10; 
var   a : array [1..n] of integer; 
  i,s1,s2 : integer; 
    begin 
 randomize; 
  for i := 1 to n do   
  begin   
   a[i] := -10+random(21); 
    writeln (a[i]);   
  end; 
     s1 := 0;
s2 := 0; 
  for i := 1 to n do   
begin 
   if a[i] > 0 then   
  s1 := s1 +a[i]; 
   if a[i] < 0 then 
    s2 := s2 +a[i];
    end;   
 writeln ('Сумма положительных=',s1); 
   writeln ('Сумма отрицательных=',s2); 
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота