В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
popdaniela820
popdaniela820
18.01.2020 13:27 •  Информатика

Задание на языке Паскаль: написать программу для вычисления значения переменной Y при условии, если Х> 2, то Y = 2Х, иначе Y = Х + 5. Использовать условный оператор If ...Then ...Else ..

Показать ответ
Ответ:
sunlight2
sunlight2
11.09.2020 21:16

Variant 1

begin

 var x := ReadInteger('Введите X:= ');

 if x > 2 then

   Println('Y:= ', 2 * x)

 else

   Println('Y:= ', x + 5);

end.

Varian 2

var

 x, y: integer;

begin

Writeln('Введите Х: ');

 Read(x);

 if x > 2 then

 begin

   y := 2 * x;

 end

 else

   y := x + 5;

 Write(y);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота