В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Иринка853653
Иринка853653
29.05.2022 14:38 •  Информатика

Задание на языке программирования Qbasic Дана последовательность натуральных чисел от 1 до 20 .
Вывести на экран из этой последовательности только тех

чисел кратных 5.

Написать программу на qbasic

Показать ответ
Ответ:
aminazhum
aminazhum
02.06.2021 17:03
 1.
#include <iostream> //если не отображается, пиши после include - iostream в <>
 using namespace std;

 int main(){
  for(int i=0;i<10;i++)
         cout<<"Hello World";
  cin.get();
  cin.get();
  return 0;
 } 11.
#include <iostream> //если не отображается, пиши после include - iostream в <>
#include <string> //если не отображается, пиши после include - string в <>
using namespace std;
int main() {
string s,p;
         cin>>s;
         cin>>p;
         if((p!="v") && (p!="g"))
         return 66;
         int n;
         cin>>n;
         if (p=="g"){
          for(int i=0;i<n;i++)
          cout<<s;
         }
         else
         {
          for(int i=0;i<n;i++)
          cout<<s<<"\n";
         }
         cin.get();
         cin.get();
return 0;
}
0,0(0 оценок)
Ответ:
eklolosmile
eklolosmile
21.12.2022 08:13
Целая часть от деления                    Остаток от деления12 div 2 = 6                                        12 mod 2 = 06 div 2 = 3                                          6 mod 2 = 03 div 2 = 1                                          3 mod 2 = 11 div 2 = 0                                          1 mod 2 = 1Остаток от деления записываем в обратном порядке. Получаем число в 2-ой системе счисления: 1100
12 = 1100|2
Для перевода дробной части числа последовательно умножаем дробную часть на основание 2. В результате каждый раз записываем целую часть произведения.
0.75*2 = 1.5 (целая часть 1)
0.5*2 = 1 (целая часть 1)
0*2 = 0 (целая часть 0)
0*2 = 0 (целая часть 0)
Получаем число в 2-ой системе счисления: 1100
0.75 = 1100|2
В итоге получаем число: 1100.1100|2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота