В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ADAMREUS
ADAMREUS
26.05.2022 17:33 •  Информатика

Задание по информатике Составить программу решения задачи:
В течение первого квартала (три месяца) рабочий получил S рублей. В январе месяце рабочий заработал A рублей, а в феврале на B руб. больше чем в январе. Определить заработок рабочего в марте.
A=5000 B=500 S=16000
A=5500 B=1000 S=20000
(В Pascal ABC)

Показать ответ
Ответ:
0508761681
0508761681
20.05.2020 09:58

import math

p = int(

b = false

for i in range(1, p ** 2):

    gip = (p ** 2) + (i ** 2)

    if math.sqrt(gip) % 1 == 0:

        b = true

        if int(math.sqrt(gip)) ! = p:

            print(int(math.sqrt(

if b == false:

    print(-1)

# что-то типо этого, но не проходит по времени. надо смотреть диапазон. может если кто дорешает, ответьте. а так всё норм работает)

0,0(0 оценок)
Ответ:
sashaloxas
sashaloxas
20.06.2021 16:02

1) для кодировки используется последовательность русского алфавита.

ключ: код

У кого сильные мышцы, тот победит одного. Кто силён знаниями, тот победит тысячи.

 

2) использыется последовательность русского алфавита, только со смещением на 1 букву. т.е. первая буква будет Я, вторая А, третья Б и т.д.

ключ: интернет

Трудно в учении - легко в бою

 

3) можно использовать код Цезаря (для кодировки нужной буквы используется буква, стоящая далее по алфавиту третьей)

ключ: длх - наименьшая единица измерения информации (бит)

ЦФТЗШ

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота