4. Сделать программу, в которой нужно ввести два целых числа и получить уведомление о том, входит ли большее из чисел в промежуток [10;20] , а меньшее в промежуток [5;8]
5. Составьте программу для табулирования функции y = x^3sin(3x) на промежутке [-2;2] с шагом 0,4, а так же вычисления произведения и количества значений, что удовлетворяют условие -1 < y < 2. Найдите сумму минимального и последнего значения функции
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016 begin var n:=ReadInteger('n='); var a:=ArrRandom(n,-50,50); Writeln('Исходный массив'); a.Println; var se:=a.Where(x->x mod 3=0); if se.Count=0 then Writeln('В массиве нет элементов, кратных трем') else begin var b:=se.Max; var i:=0; while a[i]<>b do Inc(i); if i=n-1 then Writeln('Максимальный элемент - последний') else begin Writeln('Результирующий массив'); a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println end end end.
m 8 5 n 3 ясно, что основание искомой с/с > 10. Проверим и удостоверимся, что в 11c|c действия выполняются верно. 11 c|c M=6 n = 4 ответ: основание системы 11, m=6, n=4
2. m m 65 n +2 n 4 4 m
5 5 4 2 4 очевидно, что основание искомой с/с > 6. Проверим по действиям в 7 с/с, при сложении в столбик, при m=3 и n=1 и удостоверимся, что всё верно. ответ: осн. с\с = 7, m=3, n=1
begin
var n:=ReadInteger('n=');
var a:=ArrRandom(n,-50,50);
Writeln('Исходный массив'); a.Println;
var se:=a.Where(x->x mod 3=0);
if se.Count=0 then
Writeln('В массиве нет элементов, кратных трем')
else begin
var b:=se.Max;
var i:=0;
while a[i]<>b do Inc(i);
if i=n-1 then Writeln('Максимальный элемент - последний')
else begin
Writeln('Результирующий массив');
a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println
end
end
end.
Тестовое решение:
n= 15
Исходный массив
-24 -38 15 -33 -40 -18 21 34 20 49 -19 29 29 38 -41
Результирующий массив
-24 -38 15 -33 -40 -18 21 213 20 49 -19 29 29 38 -41
1. + n 3 8 9 8
2 n 7 5 m
m 8 5 n 3
ясно, что основание искомой с/с > 10. Проверим и удостоверимся, что в 11c|c действия выполняются верно.
11 c|c M=6 n = 4
ответ: основание системы 11, m=6, n=4
2. m m 65 n
+2 n 4 4 m
5 5 4 2 4 очевидно, что основание искомой с/с > 6.
Проверим по действиям в 7 с/с, при сложении в столбик,
при m=3 и n=1
и удостоверимся, что всё верно.
ответ: осн. с\с = 7, m=3, n=1
3. пусть основание с\с будет X? тогда:
(4*X^2+X+5)*4 =2*X^3+2*X^2+6*X+6
раскрываем скобки, преобразуем и получаем уравнение:
(2*X - 14)*(X^2+1) = 0 ---> X=7
ответ:7