В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
шедвер
шедвер
15.05.2021 16:48 •  Информатика

Задания.

1. Опишите двумерный массив А, состоящий из 6 строк и 3 столбцов, элементами которого являются целые числа:



2. Опишите двумерный массив В, состоящий из 3 строк и 8 столбцов, элементами которого являются символы:



3. Дана матрица А размера 3x4. Отметьте в ней «крестиком» положения элементов А[1,3], А[2,3], А[2,4], А[3,2].

4. Дана матрица А размера 8 х 7 . В какой строке и в каком столбце стоят элементы?

А [1,7] в _ столбце, в __ строке;

А [5,3] в _ столбце, в __ строке;

А [8,2] в __ столбце, в __ строке.

5. Задана матрица А размера 5x7. Требуется вывести ее на экран так, чтобы каждая строка матрицы выводилась на экран с новой строки. Выберите фрагмент программы, в которой вывод выполняется правильно.

ответ:

1) For i:=l to 7 do

Begin

For j:=1 to 5 do

write(A[i, j] ) ;

Writeln;

End;

3) For j :=1 to 5 do

Begin

For i:=l to 7 do

write(A[i,j]);

Writeln;

End;

2) For i:=l to 5 do For j:=1 to 7 do write(A[i,j]);

Writeln;

End;

4) For i:=l to 5 do Begin

For j:=1 to 7 do write(A [i,j]) ; Writeln;

End;

6. Впишите в тексты программ операторы так, чтобы в результате были получены расположенные напротив них матрицы.

1) Program matrl;

Var Al:array[1..4,1..5] of byte;

i,j:byte;

Begin











End.

2) Program matr2;

Const n=4, m=5;

Var A2:array[1..n,1..m] of byte;

i,j:byte;

Begin











End.

3) Program matr3;

Const n=4, m=5;

Var A2:array[1..n,1..m] of byte;

i,j:byte;

Begin











End.

7. Составить программу.

Элементы двумерного массива – случайные числа, лежащие в диапазоне [0,40].

Найти минимальный элемент в каждом столбце массива.

Показать ответ
Ответ:
Алина051206
Алина051206
21.04.2023 18:19

ответ на Python:

from random import randint

a,b = [i for i in range(10,51)],[i for i in range(10,51)]

v,p = 0,0

for i in range(int(input())):

   print('Ход номер',i+1)

   q,w = a[randint(1,len(a)-1)],b[randint(1,len(b)-1)]

   v += w

   p += q

   a.remove(q)

   b.remove(w)

   print('Петя вытащил шарик с номером',q,'его счёт равен',p)

   print('Ваня вытащил шарик с номером',w,'его счёт равен',v)

if p>v:

   print('Победил Петя!')

elif p<v:

   print('Победил Ваня!')

else:

   print('Победила дружба!')

Объяснение:

0,0(0 оценок)
Ответ:
mcghcnnbn
mcghcnnbn
04.09.2022 19:51

pascal

Объяснение:

var

 p, s: real;

 x1, x2, x3, y1, y2, y3: integer;

function dlina(x1, y1, x2, y2: integer):real;

begin

 dlina := sqrt(sqr(x2 - x1) + sqr(y2 - y1));

end;

begin

 Write('Введите координаты точки A: '); ReadLn(x1, y1);

 Write('Введите координаты точки B: '); ReadLn(x2, y2);

 Write('Введите координаты точки C: '); ReadLn(x3, y3);

 p := (dlina(x1,y1,x2,y2) + dlina(x2,y2,x3,y3) + dlina(x1,y1,x3,y3)) / 2;

 s := sqrt(p*(p-dlina(x1,y1,x2,y2))*(p-dlina(x2,y2,x3,y3))*(p-dlina(x1,y1,x3,y3)));

 WriteLn('Площадь треугольника равна S = ', s:1:3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота