В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kokos5424
Kokos5424
07.11.2022 00:47 •  Информатика

Задано целое число n написать программу которая находит количество 0 в заданном числе

Показать ответ
Ответ:
yanchikkatsia
yanchikkatsia
09.10.2020 19:37

//PascalABC.NET v3.3 1633

begin

 var num:=ReadInteger('Введите число: ');

 var sum:=0;

 for var i:=1 to IntToStr(num).Length do

   if IntToStr(num)[i] = '0' then sum += 1;

 writeln('Количество нулей: '+sum);

end.

0,0(0 оценок)
Ответ:
ZorinaMasha2512
ZorinaMasha2512
09.10.2020 19:37
Java:

Scanner in = new Scanner();
String data = in.nextLine();
int counter =0;
for(char g:data.toCharArray()){
if('0'.equals(g)){
counter++;
}
}
System.out.println(counter);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота