В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Potap4uk
Potap4uk
05.02.2021 23:55 •  Информатика

Задано четырехзначное натуральное число х. составить программу с++ для получения из него числа, записанного теми же цифрами, но в обратном порядке, а так же сумму исходного и полученного числа.

Показать ответ
Ответ:
damirgaraischi
damirgaraischi
09.10.2020 20:23

#include <iostream>

using namespace std;

int rec(int a, int &b)

{

   if(a/10==0)

   {        

       return a%10;

   }    

   int t=rec(a/10, b);

   b*=10;

   return t+(a%10) *b;

 

}

int main(){

   int a, b=1;

   cin>>a;

   int f = rec(a,b);

   cout<<f<<endl;  

   cout<< f + a;

 

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота