В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
143424
143424
18.01.2020 09:22 •  Информатика

Задано натуральное число n. напишите программу, которая выведет на экран все числа от 1 до n в обратном порядке. например вводим число 5. программа выводит: 5 4 3 2 1 через пробел в строчку. язык программирования python 3.3

Показать ответ
Ответ:
maks737
maks737
24.07.2020 23:55
Python 3.4 (нет под рукой 3.3)
n=int(input("Введите N: "))
s=''
for i in range(-n,0):
    s=s+str(-i)+' '
print(s)

Тестовое решение:
Python 3.4.2 (v3.4.2:ab2c023a9432, Oct  6 2014, 22:15:05) [MSC v.1600 32 bit (Intel)] on win32
Type "copyright", "credits" or "license()" for more information.
>>> RESTART
>>>
Введите N: 5
5 4 3 2 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота