Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
даниля3
13.05.2021 09:57 •
Информатика
Задано трехзначное число, написать программу на языке паскаль, которая находит сумму его цифр и проверить четное оно или нет.
Показать ответ
Ответ:
Lizzza1111
01.10.2020 15:14
Program gt;
var s,q,n:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
writeln(s);
if(n mod 2=0)then writeln('четное')else writeln('не четное');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Nellity
07.04.2022 06:05
10 гб + 30 мб ответ в кбайтах...
abdil2017
08.03.2020 06:10
Что вычисляется по формуле N= 2i?...
MartKsenka
24.05.2022 19:40
Выполните предполагаемый проект, используя этапы решения задачи Вводится два целых числа, находится их наибольший общий делитель.Примечание. Наибольший общий делитель (НОД,...
про100Banan
18.03.2021 07:54
По требованиям эргономики свет при работе за компьютером должен располагаться...
Stefalove
04.12.2020 00:02
Написать программу в python: последовательность состоит из целых чисел и завершается числом 0. выведите, наименьший элемент, а так же какое количество элементов этой последовательности...
borisovak468
23.11.2021 00:04
Как можно научить робота двигаться по линии...
Dodgesantafe
15.09.2020 14:08
Разложи на множители многочлен 9x2 – 49....
PVA8485
01.01.2021 02:51
ДАМ 35Б как можно посчитать время работы вложенных циклов? 3)какие трудности связаны с увеличением количества вложенных циклов ? 4)Как вывести результат на экран в табличном...
Liliya000001
17.05.2021 12:43
Дан массив из 10 целых элементов Вывести сумму индексов чётных элементов...
diiiaanf101
11.09.2020 18:26
Выполните заданиеВ прямоугольнике одна из сторон равна R см, а другаясторона на D см больше. Найти площадь прямоугольника.1. Определить величины (переменные) в задаче.2. Составить...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var s,q,n:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
writeln(s);
if(n mod 2=0)then writeln('четное')else writeln('не четное');
end.