Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Ftgbjjjm
04.06.2020 21:14 •
Информатика
Задать матрицу 3 на 3,заменить элементы которые делятся на 3 без остатка, на 0,программу написать на с #
Показать ответ
Ответ:
ЕнотОбормот
05.10.2020 22:52
Using System;using System.Collections.Generic;using System.Linq;using System.Text;
namespace ConsoleApplication26{ class Program { static void Main(string[] args) { Random r = new Random(); double[,] A = new double[3, 3]; Console.WriteLine("Исходная матрица: "); for (int i = 0; i < 3; i++) { for (int j = 0; j < 3; j++) { A[i, j] = r.Next(-100, 100); Console.Write(A[i, j] + " "); } Console.WriteLine(); } Console.WriteLine("Преобразованная матрица: "); for (int i = 0; i < 3; i++) { for (int j = 0; j < 3; j++) { if (A[i, j] % 3 != 0) { A[i, j] = 0; } } }
for (int i = 0; i < 3; i++) { for (int j = 0; j < 3; j++) { Console.Write(A[i, j] + " "); } Console.WriteLine(); }
} }}
0,0
(0 оценок)
Популярные вопросы: Информатика
dinafait2001
04.12.2020 17:07
Как превратить слово барс в слово коза. постепенно меняя по одной букве. еще галка в белку и жабу в рыбу, муху в паука....
dikiyparker
04.06.2021 12:14
Что понимают под изолированной программной средой? Укажите основные элементы поддержки ИПС....
Milli205
18.10.2020 01:16
Нужно сделать на python 1. Простые задачи. Составить программу, используя цикл While. Дано натуральное n Вычислить s=1/sin1+1/(sin1+sin2)+…1/(sin1+sin2+…+sinN). 2. Принудительный...
Anglichanin228
26.01.2022 17:14
Всем ! как составить алгоритм угадай число в программе кумир ?...
Danyaukos
26.01.2022 17:14
Всем ! как построить в программе кумир буквы н и е...
няшкаморскаясвинка
19.01.2022 05:07
1. Цель и основная идея создания сайта. 2. Из каких информационных блоков состоит сайт? 3. Что определяет успех сайта в большей степени — техническая или содержательная сторона,...
tamilyamehtiev
19.09.2020 10:09
Есть двоичный код 10001100000111000000001000010000 Представить его в цифровом виде при таких кодов: 1)HDB-2 2)HDB-3 3)B3ZS 4)ПИТ 5)4В3Т...
pollyshtal33333333
22.10.2020 13:42
Використовуючи діаграми табличного процессора розв яжіть систему рівняннь графічним у=2х-3 та у=х+1 2)2х-у=-9 та 3х+2у=4 3)2х+у=-1 та 5х-3у=-19 4) 2х+3у=-1 та 4х-5у=-13...
AMORVL
15.09.2021 02:23
Как проводится коммутирование аппаратных комплексов отраслевой направленности очень и поподробнее)...
DayanaMoon2406
14.06.2022 00:29
Информатика 1.Алғашқы санау құралдары қандай болған?2. Есепшоттар әртүрлі елдерде қандай атауларға ие болды?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
namespace ConsoleApplication26{ class Program { static void Main(string[] args) { Random r = new Random(); double[,] A = new double[3, 3]; Console.WriteLine("Исходная матрица: "); for (int i = 0; i < 3; i++) { for (int j = 0; j < 3; j++) { A[i, j] = r.Next(-100, 100); Console.Write(A[i, j] + " "); } Console.WriteLine(); } Console.WriteLine("Преобразованная матрица: "); for (int i = 0; i < 3; i++) { for (int j = 0; j < 3; j++) { if (A[i, j] % 3 != 0) { A[i, j] = 0; } } }
for (int i = 0; i < 3; i++) { for (int j = 0; j < 3; j++) { Console.Write(A[i, j] + " "); } Console.WriteLine(); }
} }}