В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Задайте число в интервале от 1 до 100. составьте программу (паскаль), которая: -умножает это число на себя -складывает результат умножения с удвоенным исходным числом -делит полученную сумму на исходное число -вычитает из результата деления исходное число -выводит на экран окончательный результат

Показать ответ
Ответ:
tyutyunnik2002
tyutyunnik2002
16.08.2020 17:03
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите число от 1 до 100:');
  Writeln('Получаем ',((n*n+2*n) div n)-n)
end.

Пример
Введите число от 1 до 100: 77
Получаем 2

Замечание.
Сделаем преобразование.
(n*n+2*n)/n-n = n(n+2)/n-n = n+2-n = 2
Всегда будет получаться результат 2.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота