Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Tigrica2017
22.08.2021 18:47 •
Информатика
Заменить отрицательные элементы массива м(30) в ячейках, номера которых кратны 5, их квадратам. , .
Показать ответ
Ответ:
альбинка25
08.07.2020 08:07
Const n=30;
var m:array[1..n] of integer;
i:integer;
begin
for i:=1 to n do m[i]:=random(20)-10;
for i:=1 to n do write(m[i]:5);
writeln;
for i:=1 to n do
if (m[i]<0) and (i mod 5=0) then
m[i]:=sqr(m[i]);
for i:=1 to n do write(m[i]:5);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vitoszemko200
31.12.2021 01:37
Вставте пропущенные фрагменты в программу на языке Паскаль...
Asahimura
30.04.2020 00:11
В соответствие с кодовой таблицей ASCII каждую латинскую букву можно закодировать десятичным числом. Слово file кодируется как 102105108101. Какому слову соответствует числовая...
maksim22441
29.01.2022 07:58
Считая, что каждый символ кодируется в кодировке Unicode, оцените информационный объём следующей фразы: В шести литрах 6000 миллилитров. а) 1024 байта б) 1024 бита в) 512...
fogive
25.05.2021 17:19
Нужен краткий конспект на тему сервисы сети файловые архивы ( )...
kamilusmonov
05.07.2022 22:38
Соответствие между изображениями символов и кодами символов устанавливается с кодовой таблицыформатированиястолбчатой диаграммы...
Янаvi
06.10.2021 01:21
1.Приведите примеры информационных моделей, записанных на формальном языке. 2.Какие модели относятся к графическим информационным моделям? Приведите примеры графических...
Иван7962
22.10.2022 13:09
Исполнитель перемещается вдоль ленты, состоящей из 10 ячеек. Ячейка может быть пустой(0) или заполненной (1). Система команд исполнителя: - вправо – переместиться вправо...
hadisvv99
12.08.2021 15:08
позязя по информатике))) утром за четверть оценки высталяют! Составьте программу, которая будет находить числа - палиндромы из заданного промежутка....
9ky3ya
11.12.2020 00:38
решите это Правда это решит мою итоговую оценку...
silvia16
04.02.2021 01:57
Завдання2-5ст.99.,інформатика 6 клас...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var m:array[1..n] of integer;
i:integer;
begin
for i:=1 to n do m[i]:=random(20)-10;
for i:=1 to n do write(m[i]:5);
writeln;
for i:=1 to n do
if (m[i]<0) and (i mod 5=0) then
m[i]:=sqr(m[i]);
for i:=1 to n do write(m[i]:5);
end.