Записать что дано, найти, составить блок-схему и программу в паскале 1. Даны два числа. Возвести в квадрат те из них, значения которых
неотрицательны, и увеличить на 2,5 те, которые положительны.
2. Подсчитать количество отрицательных среди чисел a, b, c.
3. Рис расфасован в два пакета. Масса первого — Т кг, второго п
кг. Составить программу, определяющую:
а) какой пакет тяжелее — первый или второй;
6) массу более тяжелого пакета.
Var
n,m,max,min:integer;
Begin
write('Введите число: ');
readln(n);
min:=9;
max:=0;
while n>0 do
begin
m:=n mod 10;
if m<min then min:=m;
if m>max then max:=m;
n:=n div 10; end;
writeln('Максимальное число: ',max);
writeln('Минимальное число: ',min);
End.
2)
var
i,count: integer;
n,s:string;
begin
writeln('Введите число: ');
readln(s);
writeln('Введите цифру: ');
readln(n);
for i:=1 to length(s) do
if(s[i]=n)then
count:=count+1;
writeln('Количество раз, когда встречается цифра = ',count);
end.
Объяснение:одномерного массива:
varимямассива: array [нижняяграница..верхняяграница] ofтипэлементов;
двумерного массива:
varимямассива: array [нижняяграница1..верхняяграница1,нижняяграница2..верхняяграница2] ofтипэлементов;
заполение массива:
одномерный массив: for i: =1 to5do readln(a[i]); {ввод с клавиатуры}
двумерный массив: for i: =1 to3do
for j: =1 to2do readln(a[i,j]);
вывод массива на экран:
в столбец: for i: =1 to5do writeln(a[i]);
в строку: for i: =1 to5do write(a[i],' ');
матрица двумерного массива:
for i: =1 to n do
begin
for j: =1 to m do
write (a[i,j]: 4);
writeln;
end;
действия с одномерным массивом:
вычисление суммы элементов:
s: =0;
for i: =1 to n do s: =s+a[i];
подсчет элементов, удовлетворяющих условию:
k: =0;
for i: =1 tondo
if a[i] условиеотбора then k: =k+1;