Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
ЧайСПеченькой08
30.05.2022 08:37 •
Информатика
Запишите эту на паскале: дано натуральное число. определить, сколько раз в нем встречается цифра 3
Показать ответ
Ответ:
carollaim
08.10.2020 13:01
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var (n,k):=(ReadInteger('n='),0);
while n>0 do begin
if n mod 10=3 then k+=1;
n:=n div 10
end;
Writeln('Количество троек в числе равно ',k)
end.
Пример
n= 163243
Количество троек в числе равно 2
0,0
(0 оценок)
Популярные вопросы: Информатика
охххмирон228
28.02.2022 19:09
Решить информатику . фотография в закрепе. там вся инфа...
larionxam
24.07.2022 01:00
Максимум решить . ( тема-программирование) 1. написать программу, которая выводит на экран первые четыре степени числа n. 2. даны катеты прямоугольного треугольника. найти его...
ASabina1111111
31.07.2022 01:33
Напишите класс, который выводит на экран в первой строке три знака «+», во второй – четыре знака «! », в третьей – два знака «*».язык (java)...
ЕвгенийМаркауцан
14.06.2021 02:06
Напишите класс, который принимает с клавиатуры два целых числа и, если первое больше второго, выводит на экран их сумму, если же наоборот – выводит на экран их произведение....
Yuki16
10.01.2020 20:23
Напишите класс, который принимает с клавиатуры два числа и проверяет, равны они друг другу или нет.язык (java)...
recavkana
25.05.2020 06:05
Напишите класс, который принимает с клавиатуры три положительных числа и проверяет, могут ли они являться длинами сторон треугольника. по результатам проверки следует вывести...
tarasovdanila
25.01.2021 14:27
Покажите на практических примерах значение виртуального пространства...
elena111104
10.12.2021 11:07
Являются: планирование (координация во времени, в пространстве, по информации) ресурсов и элементов, подсистем и структуры системы, необходимых для достижения цели системы....
alievosman
14.03.2023 04:05
Отметьте галочкой рисунок который соответствует правилам техники безопасности...
ovezgeldyevaemi
16.09.2020 20:45
мне надо решить за 1 час...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Внимание! Если программа не работает, обновите версию!
begin
var (n,k):=(ReadInteger('n='),0);
while n>0 do begin
if n mod 10=3 then k+=1;
n:=n div 10
end;
Writeln('Количество троек в числе равно ',k)
end.
Пример
n= 163243
Количество троек в числе равно 2