// PascalABC.NET 3.2, сборка 1483 от 14.06.2017 // Внимание! Если программа не работает, обновите версию!
function ReadComplex:Complex; begin var (r,i):=ReadReal2; Result:=cplx(r,i) end;
procedure WriteComplex(x:Complex); begin if x.Imaginary=0 then Write(x.Real) else begin if x.Real<>0 then Write(x.Real); if (x.Imaginary>0) and (x.Real<>0) then Write('+'); Write(x.Imaginary,'i') end end;
begin var n:=ReadInteger('N ='); Writeln('Введите ',n,' комплексных чисел'); Writeln('Формат ввода числа: действ.часть, пробел, мнимая часть'); var s:=cplx(0.0,0.0); loop n do s+=ReadComplex; Write('S='); WriteComplex(s) end.
Пример N = 5 Введите 5 комплексных чисел Формат ввода числа: действ.часть, пробел, мнимая часть 2.3 -3.12 -1.7 8 6.14 0.2 -2.4 -3.2 0 1.6 S=4.34+3.48i
1.
program z1;
var a:array [1..10] of integer;
i,k:integer;
begin
write ('Введите элементы массива через пробел и нажмите Enter ');
for i:=1 to 10 do read (a[i]);
write ('Массив: ');
for i:=1 to 10 do write (a[i],' ');
writeln;
write ('Номера элементов больше 5: ');
for i:=1 to 10 do if a[i] > 5 then
begin
write (i,' ');
k:=k+1
end;
writeln;
writeln ('Элементов больше 5: ',k)
end.
2.
program z2;
var s:string;
begin
readln (s);
while pos('о',s)<>0 do delete(s,pos('о',s),1);
writeln(s)
end.
Объяснение:
Смотри картинки
2. Программа удаляет только строчные русские о
// Внимание! Если программа не работает, обновите версию!
function ReadComplex:Complex;
begin
var (r,i):=ReadReal2;
Result:=cplx(r,i)
end;
procedure WriteComplex(x:Complex);
begin
if x.Imaginary=0 then Write(x.Real)
else begin
if x.Real<>0 then Write(x.Real);
if (x.Imaginary>0) and (x.Real<>0) then Write('+');
Write(x.Imaginary,'i')
end
end;
begin
var n:=ReadInteger('N =');
Writeln('Введите ',n,' комплексных чисел');
Writeln('Формат ввода числа: действ.часть, пробел, мнимая часть');
var s:=cplx(0.0,0.0);
loop n do s+=ReadComplex;
Write('S='); WriteComplex(s)
end.
Пример
N = 5
Введите 5 комплексных чисел
Формат ввода числа: действ.часть, пробел, мнимая часть
2.3 -3.12
-1.7 8
6.14 0.2
-2.4 -3.2
0 1.6
S=4.34+3.48i